Receiving error "An error occurred while processing the response"; Corruption
Potential Symptoms
- Receiving the following alert in Venus: "An error occurred while processing the response", but status is received.
- May receive a secondary alert such as "Name cannot begin with '0' character, hexadecimal value 0x30. Line2, position 29".
- May receive a secondary alert such as "Name cannot begin with '0' character, hexadecimal value 0x30. Line2, position 29".
- Unable to send, update, retrieve, or remove content or schedules with Venus software but can connect with M2Config and able to automatically detect the display with no issues.
- Unable to retrieve status in Venus 1500.
- May occur with display controllers with no messages sent/stored on it (new controller).
- May also see the following errors in Venus 1500: Data Access Error: There is insufficient system memory in resource pool "internal" to run this query or There is insufficient system memory in resource pool "internal" to run this query.
- May see the following error in the Venus 1500 error logs: "Data access error: Duplicate entries not allowed."
Environment
- Product: AF-3150, AF-3160, AF-3165, AF-3180, AF-3190, AF-3197, AF-3200, AF-3220, AF-3400, AF-3500, AF-3550, AF-3700, Electronic Message Center (EMC) or Board (EMB), Marquee, Readerboard
- Component: M2 & M3 controller based products
- Control System: Venus 1500, Version 4
Cause
- Message, schedule, or memory on the controller is corrupt or unreadable.
- Messages on the display that have a special character in the name of the message can trigger this alert.
- The naming scheme may have been ok in V3 but V4 needs an Alphanumeric naming scheme.
- Issue may be seen more frequent when updating from V3 to V4 software.
Resolution
Step 1: Clear the display memory.
- Follow How do I clear the display memory in Venus 1500 v4, DD2078733.
- If unable to clear memory using Venus software follow How to perform a memory reset using the M2Config utility?, DD2347391.
Connect with Venus 1500 v4 after the display reboots and verify the alert has cleared.
- Step 2: Republish content to the display.
- Follow How do I publish or remove a message or presentations to or from display in Venus 1500 v4, DD2093330.
- If the issue returns after republishing content, check the names of all messages being sent to the display and remove special characters from the message names.
- After changing the content naming, go back to step 1.
KB ID: DD1990364
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