Error when trying to open Content Studio from remote clients

Potential Symptoms

  • When trying to open Content Studio from Vanguard remote client I get the following error:  Content Studio experienced problems when starting and will have to close.
    Capture 1.PNG

Environment

  • Product Family: Transportation
  • Product: Vanguard Professional software v4.27.0.39
  • Component: Content Studio
  • Control System: Vanguard Professional Software installed as a client (remote pc connection to server)

Cause

  • The endpoints in Content Studio.exe.config are set to localhost or do not point to the correct server.

Resolution

  • Until an update to Vanguard v4.27.0 becomes available, install Vanguard v4.26.1 on the remote clients.  Server can remain at Vanguard v4.27. 

For Temporary Operation

Edit the Content Studio.exe.config file located in C:\Program Files (x86)\Daktronics\Content Studio\ and change all the endpoints to point to the correct server:

Example:

Original endpoint

<endpoint name="SystemManagementService" address="net.tcp://localhost:9245/SystemManagementService" binding="netTcpBinding" contract="Daktronics.Nucleus.ServiceContract.ISystemManagementService" bindingConfiguration="systemManagementServiceNetTcp">
</endpoint>

New endpoint

<endpoint name="SystemManagementService" address="net.tcp://Server's IP Address:9245/SystemManagementService" binding="netTcpBinding" contract="Daktronics.Nucleus.ServiceContract.ISystemManagementService" bindingConfiguration="systemManagementServiceNetTcp">
</endpoint>

KB ID: DD4264688


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