NovaStar: Blank cabinets of display; Receiver card failure

Potential Symptoms

  • All cabinets are blank after a receiver card ( if no redundant signal)
  • How to judge receiver card failure for J Series and L Series displays?

Environment

  • Product: Nova MCTRL 660, MRV300Q,  NovaStar brand sender box and receiver  cards
  • Components: NovaLCT-Mars
  • Control System: Gold family or NPP Control using transmit common/open protocol, includes but not limited to DVN-4003, J Series, U Series, Q Series

Cause

1. If one RC card is fails, it will lead to all cabinets are blank after this RC( if no redundant signal).

RC failure.jpg 

You can use the NovaStar software (pictured above) to identify receiver cards not communicating the sending box/card.  Send configuration parameters to each receiver card.   If are not able to send the parameters to the receiver card, you will know that the receiver card is not communicating.

Resolution

  1. Make sure power is going to the card
    • The cards in the cabinet should have a solid red light and a green flashing light. 
  2. Check the cat 6 cable from the sending card to the receiver card. Swap this out for a new cable if necessary.
  3. Replace the receiver card with a new one and cycle power to the entire display.
    • After replacing a receiver card, if the section is blank, try sending receiver card configuration to the specific receiver card instead of sending it to all.
      • Reference "DD3242867, How to Configure a Sender Box " for instructions on how to load and send the receiver card configuration file.  It may take some time for the new receiver card to read the config from the sending box.  Switch the display to test pattern and then back to normal content to force it to take the new config data faster.
    • If the recently replaced section still appears blank, or bright white, it might be because the new receiver card has not read the dimming values yet.  Switch the display to test pattern and then back to normal content to force it to quickly read the correct dimming levels. 

RC card.jpg 

Related Resources

How to judge receiver card failure NovaStar controlled display?

Daktronics L Series Displays- Removal and Installation of an L Series Receiver and Hub Card

Daktronics J Series Displays- J10 Replacing a Hub and Receiver Card

How to judge a HUB board failure ?

How do I replace a receiver card in a DVN-4003 display?

KB ID: DD3345185


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.