Receiving error 'System.ServiceModel.FaultException: Data Access Error:' when trying to save a presentation in Content Studio

Possible Symptoms

  • Receiving error 'System.ServiceModel.FaultException: Data Access Error:'Error:
    System.ServiceModel.FaultException: Data Access Error: Violation of PRIMARY KE constraint 'DBO_Files_fileID_PK'. Cannot insert duplicate key in object 'dob.files'.

    DD2403500_1.jpg

Environment

  • Product Family:
  • Product: 
  • Components: Content Studio
  • Control System: Venus 1500 Version 4, Display Studio

Cause

  • When trying to save the presentation, there is a duplication error happening within the database. 

Resolution

Option 1: Copy each individual slide in the presentation and paste into new presentation.

  • As each slide is pasted into the new presentation attempt to save it to locate which slide is causing the issue.
  • Once a slide has been identified copy the content of the file and past it Microsoft word.
    • On the home tab click the button that looks like a backwards P with a line through it. This will show you all hidden characters.
  • Look for any extra returns paragraph markers that are between words or letters.
    • After removing all unnecessary hidden characters copy the text and paste it back into content studio making sure to attempt a save.

Option 2: Create a NEW database, attempt to reload existing database follow: How do I use the Nucleus Server Database utility to transfer or save a database?, DD1705994

  • Be sure to save a copy of the current Database, before proceeding with a New Database. There is a potential that the Database is corrupt and will not be functioning so creating a backup may not prove useful.
  • Attempt to reload the Database may resolve the issue. Follow the article above to save the existing and create the new Database.

KB ID: DD2403500


Fill out my online form.
DISCLAIMER: Use of this content may void the equipment warranty, please read this DISCLAIMER prior to performing any service of the equipment.