Prolific USB to serial adapter driver not installing correctly, yellow ! in device manager; Driver/Chipset issue

Potential Symptoms

  • USB to Serial driver does not install correctly.
  • Error log in Venus 1500 Device Manager shows error -10 and -12.
  • USB to serial driver shows up with an issue (yellow exclamation) in device manager.
  • Sign running, but no communication.
  • Installing prolific adapter on another computer results with the same errors.
  • Error in device manager indicates "a device which does not exist was specified".
  • "Connect Failed" alert in Venus 1500 V4.
  • Device Manager shows error code 28 next to unidentified device.

Environment

  • Product Family: Message Displays
  • Product:
  • Component: Prolific USB to Serial Adapter, Serial Communications
  • Control System: 

Cause

  • Driver/chipset issue.
    • If you are getting an Error Code 10 with a yellow exclamation mark in Device Manager after installing the latest Prolific PL-2303 driver, please contact the cable maker of your product for Prolific chip validity and support

Resolution

  1. Unplug all USB-To-Serial adapters from your computer — and Double click on the installer saved in above steps.
  2. When it prompts you, plug in one (1) of your USB-To-Serial adapters and click "Continue".
  3. Run the installer program. If it offers a choice to remove the driver, then select to remove the current "bad" driver. Then run the installer again to install the correct driver.
  4. Reboot your computer.

Work Around

  • Order a Moxa USB to Serial cable for replacement.
    • Contact Daktronics technical Support, 1-888-325-7446.

KB ID: DD2090456


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