Venus 1500 v4 application hangs or gives Nucleus error when launching; Antivirus blocking services

Potential Symptoms

 
  • When attempting to launch Venus 1500 v4, the splash screen just seems to hang, does not launch and does not prompt for credentials or show any errors.
  • When trying to launch Venus 1500 v4, receive Nucleus Error and Username and Password Prompt.
  • Launching Venus 1500 v4 and receive error: "The SQL Server (NUCLEUS) service is not running Please try restarting this machine or running as administrator."
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  • When entering in Default Username and Password, received the following error(s):
    • An error occurred while logging in: credential store is not accessible. Ensure that the SQL Server (NUCLEUS) service is running.
    • Nucleus Services is not Running. Nucleus Service has failed to load.
  • When checking services, all services show running.
  • When checking Nucleus Server Error.log, see the following possible errors:
    • A TCP error (10013: An attempt was made to access a socket in a way forbidden by its access permissions) occurred while listening on IP Endpoint=0.0.0.0:9245.
    • Title: Error during setup of users and roles.
      Message: Unable to connect to the remote server.
      Unable to connected to the remote server ---> System.Net.Sockets.SocketException: The requested address is not valid in its context [2001:0:9d38:953c:34ca:399:3F57:fed6]:8811
    • DD1715361 1.jpg
  • Fusion Service will not start properly and see the following error in Fusion Event Logs.
    • An unexpected socket exception occurred when sending data. See inner exception for details. A socket operation was attempted to an unreachable host.
    • Could not find the local Fusion service.

    Environment

    • Product Family: Software
    • Product: Venus 1500 v4.22
    • Component: Daktronics Nucleus Server service, Anti-Virus Software Firewall (McAfee, AVG, Norton 360, Symantec, Windows Essentials, PANDA, Security Manager AV Defender, N-able Technologies, Sophos Protection, etc.)
    • Control System: Venus 1500 v4

    Cause

    • An antivirus or firewall program is blocking Venus services from starting properly.

    Resolution

    Step 1: Unblock the Daktronics NucleusServer.exe, Fusion and Venus 1500 from the antivirus/firewall application along with any client applications.
    NOTE: this can be accomplished in most cases by adding exceptions in the antivirus for the Daktronics folder in the C:/Program Files and C:/ProgramData directories
    • Follow the Anti-Virus Manufacturer Help Guide for assistance, the instructions are different based on brand and version.
    • Firewall may need to be turned off during the use of Venus 1500, even with exceptions made.
    • For a list of ports Venus 1500 V4 uses, see article: What are the Venus 1500 v4 System Default Ports? DD2509428
    Step 2: Restart Daktronics Nucleus Server services once changes have been made to ensure that the service is started up properly.  How do I manually start/restart or stop the Daktronics Fusion and Nucleus Server and SQL Server?, DD2236444.
     

    Note: In some cases, McAfee Anti-Virus has had to be removed from a computer completely. The Fusion Server, sometimes even with full access granted, still is blocked and this prevented the use of the Venus 1500 software. For a list of suggested Antivirus Clients see article: What antivirus software is recommended or supported on Daktronics supplied computers? DD2079868

    For Temporary Operation

    • Set Venus to run as Administrator. 

    KB ID: DD1715361


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