Fusion service not loading, started and then stopped; Certificate corruption or missing

Potential Symptoms

  • When launching Venus 1500, it goes right to Username/Password prompt, and it never did before.
  • When launching Venus 1500, it will show Starting Fusion Service...but it just hangs there without generating an error or UN/PW prompt.
  • After a fresh installation of Venus 1500 v4 and attempting to launch the software, get the error "Verifying services loaded failed. service Daktronics fusion was not found on the computer"
  • The Daktronics Fusion Service will not start and keep receiving the following error:
    • The Daktronics Fusion service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs4-23-2013 1-59-35 PM.jpg
  • Fusion service event log show the following Certificate error in the event logs:
    • InvalidOperationException: No matching SSL Certificate found
      • 4-25-2013 1-15-48 PM.jpg
  • When following the article that the Daktronics Fusion Service is not installed, DD2504782, you may receive the following error:
    • Error 1920. Service Daktronics Fusion (Daktronics.Fusion) failed to start. Verify that you have sufficient privileges to start system services.

4-23-2013 2-09-36 PM.jpg 

  • May also receive Error: 1053: The service did not respond to the start or the control request in a timely fashion.
  • Could also get error 'The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
  • Venus getting stuck on splash screen showing "Nucleus Service Loading".

Environment

  • Product:
  • Component: Daktronics Fusion
  • Control System: Venus 1500 v4.18.1 and greater

Cause

There is an issue in Fusion that if you have any type of certificates in the Personal folder that match the computer name it will cause corruption or certificate generation.

Resolution

Begin by verifying that there is a Fusion certificate in the personal folder in MMC - follow steps 1-8 to access the Personal folder in the MMC.
  • If there is no Fusion certificate present in the Personal folder follow the remainder of the steps in the resolution.
Steps in MMC:
  1. Go to Windows Start Menu:
    • Windows XP - Click Run, type MMC, and hit [Enter].
    • Windows Vista or 7 - In the Search Programs and Files, type MMC, and select MMC from the filtered Start Menu.
    • Windows 8 - Hover to the bottom right of the desktop, click Magnify Glass, type MMC, and hit [Enter].
    • Windows 10 - Click the start button, type MMC, and hit enter
  2. From the MMC Console, click File -> Add/Remove Snap-in.
  3. Under the Available snap-ins menu, select Certificates and click Add > to push to the Selected snap-ins menu.
  4. From the pop-up window, select Computer Account and click Next.
  5. Leave on or select Local Computer and click Finish.
  6. Click Ok.
  7. In the left side panel, under Console Root, double-click on Certificates (Local Computer).
  8. Double-click on Personal -> Certificates.
  9. Do you see any certificates by any publisher (other than Daktronics Fusion) listed that show the computer name?  *If this is a Daktronics Employee's PC, please see Internal notes below before continuing to the next steps*
  10. Yes - Drag and drop any/all certificates from Personal down to an empty folder such as Trusted People or Other People. (Double click the other folders to make sure they are empty before dropping other certificates in there.

6-20-2018 11-24-31 AM.png

  • No - Run a repair on Fusion and check if the certificate is showing after repair. This can be done by restarting the Daktronics Fusion Service.
  1. Once Certificates are dragged to a different folder, go to Services, locate and restart or start Daktronics Fusion service.
  2. Follow How do I manually start/restart or stop the Daktronics Fusion and Nucleus Server and SQL Server? DD2236444
  3. Check in the Personal/Certificates folder to make sure the Daktronics Fusion CA certificate is generated.
  4. You will need to click the refresh button to refresh the view in the MMC ConsoleDD2535149 3.jpg
  5. If the Daktronics Fusion CA appears in the folder, drag the other certificates that you moved, back into the Personal/Certificates folder.
  6. If the Certificate does not generate after starting/restarting Fusion service, attempt to run a repair on Fusion.
  7. Once certificates are all in place, close MMC and try and launching Venus 1500 v4.

KB ID: DD2535149


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