Receiving Nucleus Error and in Nucleus Error Logs receiving error "Cannot find the X.509 certificate using the following search criteria"
Potential Symptoms
- When launching Venus 1500 v4, receiving a Nucleus error.
- When launching Venus 1500 v4, the software prompts for a username and password when it hasn't done so in the past.
- When reviewing Nucleus Error.log, see the following error:
- Windows 64 Bit System: C:\Program Files (x86)\Daktronics\Nucleus Server
- Windows 32 Bit System: C:\Program Files\Daktronics\Nucleus Server
- Cannot find the X.509 certificate using the following search criteria: StoreName 'Root', StoreLocation 'LocalMachine', FindType 'FindBySubjectDistinguishedName', FineValue 'CN=Daktronics Nucleus'.
- When viewing certificates may encounter duplicate certificates for Fusion under different users.
- There may be no certificates.
Environment
- Product Family: Software
- Product:
- Component:
- Control System: Venus 1500 v4 (Content Studio)
Cause
- User Log-in does not have proper access, privileges or rights to the Local Computers Certificates or the certificate did not install properly.
Resolution
- Upgrade to latest version of Venus 1500. (If this doesn't resolve it see For Temporary Operation below.)
For Temporary Operation
- Check to verify what certificates are installed.
Microsoft Management Console (MMC)
- Go to Windows Start Menu:
- Windows XP - Click Run, type MMC and hit [Enter].
- Windows Vista or 7 - In the Search Programs and Files, type MMC, select MMC from filtered Start Menu.
- Windows 8 - Hover to bottom right of desktop, click Magnify Glass, type MMC and hit [Enter].
- Windows 10 - In the Search bar bottom left, type MMC, select MMC from filtered Start Menu.
- May need Administrator rights to complete the following steps.
- From the MMC Console, click File -> Add/Remove Snap-in.
- Under Available snap-ins menu, select Certificates and click Add > to push to Selected snap-ins menu.
- From the Pop-up window, select Computer Account and click Next.
- Leave on or select Local Computer and click Finish.
- Click Ok.
- In the Left side panel, under Console Root, double-click on Certificates(Local Computer).
- Double-click on Personal -> Certificates.
- Check to see what if any certificates are in place.
- Delete any Fusion certificates.
- Restart the Daktronics Fusion Service
If the above steps do not resolve the issue.
KB ID: DD2630158
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