Receiving SQCMD error code: 1, Services locked up.

Potential Symptoms

  • When updating Display Studio receive the following error:
    • SQLCMD returned error code:1
      Log file: [pathway to log file]
    • 8-14-2013 9-28-35 AM.jpg
  • When going to the log file directed to in the received error (Make sure to follow the path on the actual error, not the one in the screen shot above:
    • Could not find database ID6, name 'Nucleus Log'. The database may be offline. Wait a few minutes and try again.
    • 8-14-2013 9-28-44 AM.jpg
  • When clicking OK to the SQLCMD Error, the install does a rollback.

Environment

  • Product Family: Software
  • Product:
  • Component:
  • Control System: Display Studio, Venus 1500 v4

Cause

  • Services or Database is possibly locked up and is inaccessible.

Resolution

Step 1: Stop the Daktronics Nucleus Server & Daktronics Fusion (if listed), do not stop the SQL Server (Nucleus).
Step 2: Run the Nucleus Database Diagnostics Utility.
  1. Go to the following web location:
  2. Click Save As, and save ZIP File to the Desktop.
  3. Right-click the Nucleus Database Diagnostics.zip and choose Extract all.
  4. Click Finish or Next.
  5. Double-click and run the Nucleus Database Diagnostics utility.
  6. Click Detach next to both Database and Log.
  7. Once they say detached, click Attach.
  8. Close the Diagnostics utility and keep the Daktronics Nucleus Server and Fusion Server stopped.

Step 3: Re-run the Display Studio Installer/Update.

Note: This may fix same install error listed in the log file with Venus 1500 v4.

KB ID: DD2612468


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.