When auto-detecting display in Venus 1500 v4.18 receive prompt to authenticate or User Not found when manually configuring display

Potential Symptoms

  • When auto-detecting display in Venus 1500 v4.18 receive prompt to authenticate.
    • Authentication.
    • A Daktronics display has been detected but requires a password before auto detection can complete. Enter the password and click "Continue" to complete detection and configure the detected display with this password.
    • software password.JPG
    • Any password entered does not work.
  • After Auto-detect fails, receive error 'User Not found' when manually configuring display.
    • 1-4-2013 11-21-16 AM.jpg
  • When looking at the Event Viewer, see the following MSSQL$NUCLEUS error:
    • FCB::RemoveAlternateStreamsByHandle(BackupSeek): Operating system error (null) occurred while creating or opening file 'C:\Program Files\Microsoft SQL Server\(Folder name will very)\MSSQL\DATA\Nucleus Log.mdf'. Diagnose and correct the operating system error, and retry the operation
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  • When trying to run the Nucleus database Diagnostic tool, receive the following error:
    • An error occurred while retrieving database status for Nucleus Database. The type initializer for 'System.Data.SQLClient.SQLConnection' threw an exception.
      DD2504673_2.jpg
  • Because this is a new database and when trying to restore a new database to the computer, you receive the following error when using the Database Utility:
    • SQLCMD returned error code: 1
    • Log file: C:\Program Files\Daktronics\Nucleus Server\Logs\Install\Nucleus Database (dbo) v1.log
      DD2504673_3.jpg
  • When viewing the log file directed in the SQLCMD Error, you see the following error:
    • sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : Cannot generate SSPI Context.

Environment

  • Product Family: Software
  • Product:
  • Component: Microsoft SQL
  • Control System: Venus 1500 v4.18 or greater

Cause

  • There is an issue with the Microsoft Operating System SQL Server Protocols or the Network that is not allowing our software to configure the SQL Server for Venus 1500 v4.

Resolution

Step 1: Disconnect computer from the Network and try installing Venus 1500 v4 again.

  • Make sure the computer is not plugged into any Ethernet or connected to a Wireless Network.
  • You do not need to be connected to the internet to install Venus 1500 v4.
  • If removing computer from the network does not resolve the issue, proceed to step 2.

Step 2: Change SQL Server 2008 Protocol Settings.

  • The following resolution may or may not resolve the issue. The suggested settings below to change may be unique depending on if the Computer is or is not hooked up to a Network Domain. Please reference the following BLOG for more information if the below suggestions do not help: Cannot generate SSPI context
  1. Launch the SQL Server Configuration Manager.
    • SQL Server 2005 - Click Windows Start Menu -> Programs/All Programs -> Microsoft SQL Server 2005 -> Configuration Tools
    • SQL Server 2008 - Click Windows Start Menu -> Programs/All Programs -> Microsoft SQL Server 2008 -> Configuration Tools
  2. From the left menu, click on SQL Server (2005 or 2008) Network Configuration.
  3. Double-click on Protocols for NUCLEUS.
    • This may not be available if Venus 1500 v4 is not fully installed, continue to step 6.
  4. Make sure Named Pipes is Enabled.
    • Right-click on Named Pipes, choose Enable.
  5. May need to enable or disable TCP/IP. (This setting may very depending on Network Requirements.)
    1. Right-click on TCP/IP, choose Enable or Disable.
  6. From the left menu, click on SQL Native Client Configuration.
  7. Double-click on Client Protocols.
  8. Make sure the following named are in the properly listed order:
    • Shared Memory - 1 - Enabled
    • TCP/IP - 2 - Enabled 
      • This may need to be disabled, by right-click and selecting Disable.
    • Named Pipes - 3 - Enabled
      • This may need to be enabled, by right-click and selecting enable.
  9. From the left menu, click on SQL Server (2005 or 2008) Services.
  10. Right-click on the SQL Server (NUCLEUS), click Stop.
    • Allow process to complete.
  11. Right-click on the SQL Server (NUCLEUS), click Start.
    • Allow process to complete.
  12. Retry installing Venus 1500 v4.

Work Around

The below options should not be performed by any Daktronics Support Technician. We also do not support or troubleshoot if the workarounds do not resolve the issue or breaks the computer. Proceed at your own risk.

  • Option 1: User will need to work with their Computer IT Department on trying to resolve the security issue. Please view the below Microsoft Article on the related issues:
  • Option 2: If the resolution or work around does not resolves the issue, either a System Restore or a Reformatting of the Windows Operating system may be required.

KB ID: DD2504673


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