"Venus 1500 has encountered a problem and needs to close" when connecting to the display and then stops the Nucleus Server

Potential Symptoms

  • Venus 1500 v4 software launches, but soon as communication is attempted to display receive the following error:
    • Venus 1500 has encountered a problem and needs to close. We are sorry for the inconvenience.
    • 1-4-2013 8-14-59 AM.jpg
  • After software crashes out, you receive a Nucleus Error and the Nucleus Service is no longer started, you have to restart and same issue repeats.
  • View the following error in Event Logs:
    • .NET Runtime Error
    • Nucleus Server.exe 'The process was terminated due to an unhandled exception.
    • NETRuntimeNucleus.jpg

Environment

  • Venus 1500 v4

Cause

  • There is a corrupted LOG.XML file out on the controller.

Resolution

Step 1: Connect to display in M2Config.

  1. Follow DD2342173 on how to connect to your display in M2Config.

Step 2: Delete the LOG.XML File from the controller.

  1. Once connected in M2Config, go to File Transfer tab.
  2. Locate and select the LOG.XML file, and click center arrow pointing left to send to desktop.
  3. Allow transfer to complete.
  4. Locate LOG.XML file on desktop, right-click choose Open With... and select Notepad or Notepad++.
    • If in Notepad, it will be completely empty.
      • Bad log examples:
        • CorruptedLog.PNG
        • 1-14-2013 9-37-48 AM.jpg
      • Good log example:
        • 1-14-2013 9-45-41 AM.jpg
    • If in Notepad++, it will say NUL through out the log.
      • Bad log example:
        • 1-14-2013 9-34-12 AM.jpg
      • Good log example:
        • 1-14-2013 9-34-42 AM.jpg
  5. If the LOG.XML file is bad and either is empty or shows NUL you need to delete from the controller.
  6. While in the main directory, select the LOG.XML file, click Delete in the bottom right.
  7. Click the Folder in top right, choose _Flash, click Ok.
  8. Select LOG.XML and click Delete in the bottom right.
  9. Click Tools tab, under Reset Display, click Reset.
    • This will generate a new LOG.XML File on the controller.

Step 3: Re-launch Venus 1500 v4 as normal.

KB ID: DD2461526


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