Receiving error "Database 'Nucleus Log' cannot be opened due to inaccessible files or insufficient memory or disk space" when trying to installed or update Venus 1500 v4, Compressed files in server folder.

Potential Symptoms

  • Receiving "Database 'Nucleus Log' cannot be opened due to inaccessible files or insufficient memory or disk space" when trying to installed or update Venus 1500 v4
  • Error 1:
    The SQL Server Setup cannot install files to the compressed or encrypted folder: c:\Program Files\Microsoft SQL Server\. To continue, make sure that your installation directors are not compressed or encrypted, or specify a different directory, and then run the SQL Server Setup again.
  • Error 2:
    Database 'Nucleus Database' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server errorlog for details.
  • Error 3:
    Look for files\folder names that appear blue in the following locations, they could be the main folder, or sub folders/files:
    • C:\Program Files\Daktronics
    • C:\Program Files\Microsoft SQL Server
    • Example of what a compressed file/folder will look like, the file or the folder will be blue.

Environment

  • Product Family: Software
  • Product:
  • Component:
  • Control System: Venus 1500 (4.17), M3

Cause

  • This is caused by having compressed files/folders within C:\Program Files\Microsoft SQL Server folder.

Resolution

Important: The following steps require a significant amount of technical knowledge. It is recommended for User to seek assistance from their IT or Technical Department or Daktronics Software Support.

  1. Stop the SQL Server (Nucleus). Refer to How do I manually start, restart or stop the SQL Server (NUCLEUS), Daktronics Fusion and Daktronics Nucleus Server services?, DD2236444 for instruction on how to stop services.
  2. Locate compressed files and uncompress them.
    • Go to C:\Program Files or C:\Program Files (x86).
      • Go into Microsoft SQL Server -> MSSQL.1 (.can vary) -> MSSQL -> Data.
  3. Look to see if any files show blue text (Especially the Nucleus MDF, LDF file types).
    1. If Yes, go back to the Microsoft SQL Server folder, Right-click and choose Properties.
    2. From the General Tab click Advanced.
    3. Uncheck Compress contents to save disk space -> click Ok.
    4. Choose Apply changes to this folder, subfolders and files, click Ok.
    5. Run update/repair on software.

NOTE: If the "Compress contents to save disk space" is not checked, try checking it and click ok and apply changes to the folder, subfolders and files. Then follow the instructions in step three. You may also need to run the Nucleus Database Diagnostics and repair or detach and attach the databases.  May also need to manually create necessary folder and then uncompress it.

KB ID: DD2275326


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.