Content Studio loads and crashes when it loads the media library and give error - Encountered problem and needs to close

Potential Symptoms

  • Content Studio loads and crashes when it loads the media library and give error - Encountered problem and needs to close.
  • DIVX or other programs that may interfere with Content Studio Not installed
  • Error in Content Studio.log:
    BitmapImageHelper.LoadFromMemoryStreamEx() encountered exception:System.NotSupportedException: No imaging component suitable to complete this operation was found. ---> System.Runtime.InteropServices.COMException (0x88982F50): Exception from HRESULT: 0x88982F50

Environment

  • Venus 1500 (4)
  • Scheduling
  • M3

Cause

  • The media library plug-in is trying to load files either from Daktronics Library folder or another folder location that has a bad file. When it tries to load the bad file, it causes an error and crashes Content Studio and shows an error in Content Studio.log file.

To Verify issue Option 1:
  1. Go to the following computer location:
    • Windows  XP - C:\Documents and Settings\All Users\Application Data\Daktronics\Content Studio
    • Windows Vista/7 - C:\Program Data\Daktronics\Content Studio
  2. Double-click to open the Content Studio.log text document. 
  3. Look for the following type of error (Screen shot below highlighted in yellow of the exact error.
    1. This error could appear anywhere within the log file. It can appear in the beginning, middle or end of a time stamp.

Example of error showing at beginning of time stamp


  • Example of error showing at middle or end of time stamp.

    To Verify issue Option 2:
    1. Navigate to the location of where the Media Library is browsing to.
      • This could be the Media Kit, My Pictures, My Documents etc.
    2. Look for a file that does not have a thumbnail image like the rest. (see screen shot below of sample bad images)

    WINDOWS XP BAD FILE THUMBNAIL                    WINDOWS 7 BAD FILE THUMBNAIL


    Resolution

    1. Navigate to the location of where the Media Library is browsing to.
      • This could be the Media Kit, My Pictures, My Documents etc.
    2. If browsing to the Daktronics Library use the below pathways to locate the folder.
      • Windows XP - C:\Documents and Settings\All Users\Shared Documents\My Daktronics
      • Windows Vista\7- C:\Users\Public\Public Documents\My Daktronics
    3. Right-click the bad file, select Delete.

    NOTE: If the media library is not directing to the Daktronics Library delete the bad image file from the last searched location. Follow the work around to find out where the last search location was.

    Work Around

    If you are unable to determine which file is the issue and would like to get the content studio to stop crashing do the following:

    1.  Go to the following location:
      • Windows XP - C:\Documents and Settings\All Users\Application Data\Daktronics\Content Studio
      • Windows Vista\7 - C:\Program Data\Daktronics\Content Studio
    2. Right-click on CSSettings.xml, choose Open With, Select Notepad.
    3. Scroll to the bottom of the data and under Plugin Settings change LastSearchImageDirectory value from the current path, to a different pathway.
      • Change the pathway after value=" to a new pathway.
    4. Click File -> Save.


    Example: The bad path is C:\Users\Steve\Documents\DQ\Daktronics
    The different path would be to the Media Library or maybe the Desktop. This will change where the media library defaults to so the content studio will stop crashing until the User figures out which file is bad. (see screen shot below, yellow is a good path to change to)

     Using the following:  value = "Daktronics Content Library" can be used to reference C\Users\Public Documents\My Daktronics path



    KB ID: DD2142775


    DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

    DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

    The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.