Galaxy Display using Serial Radios, Communication to display is intermittent or not occurring

Potential Symptoms

  •  Will get one of the following scenarios:
    1. Cannot publish content to display.
    2. All content will publish to display but messages will be sitting in stored messages with none running.
      • May receive following error messages either during or after publishing content.
                  - "message file name" bad command.
                  - Bad command.
                  - Invalid response.
                  - "schedule file name.M2S" not found.
      • Some content will publish and play on display while other messages that should be playing will not.
    3. May be able to start test pattern.
    4. Display may have run fine for a period of time before problem became noticeable.
    5. May be able to connect with M2config and multiplier setting is set to 1 for serial communication.

Environment

  • Product: Galaxy
  • Component: Gen 2 & Gen 3 Serial radios
  • Control System:

Cause

  • Improper installation of radios.

Resolution

  • Do evaluation of radio install and correct any issues found.
  • Use following guidelines to ensure proper installation of radios:
    1. Mount radios outside in line of sight of each other with antennas parallel to each other and securely tightened to radio body; no objects should be between radios; take into account Fresnel zone (area around the visual line-of-sight that radio waves spread out into after they leave the antenna. This area must be clear or else signal strength will weaken.),  and distance between radios should be less than 1500 ft.
    2. If trees, bushes, snow piles, automobiles, or other possible obstructions are nearby ensure that it will not obstruct the line of sight of the radios.
      • The Fresnel zone does have a tough time passing through trees, the main reason is due to the high levels of moisture or water content in trees.  Radio waves in the 2.4 GHz band absorb into water quite well.
    3. Mount radios upright with clear, free space in a 360 degree radius around antennas.
    4. Signal wiring going to radios should not be run alongside power/electrical wiring or over fluorescent/neon ballasts.
    5. Avoid installation of radios at sites that may have other wireless communication equipment in the 2.4 GHz range or equipment that may cause RF interference such as electrical substations.

Additional Comments

  • It is not uncommon for a site to have no perceived communication issues with an improper installation of wireless/radio communication equipment for a varying length of time (sites may have no communication or perceived communication problems for several years sometimes).
  • However, sometimes additional wireless equipment might have been added over the years in the area which may be adding noise to the frequency range being utilized by the radios. Serial radios operate in the 2.4 GHz range; many other devices operate in this same range (e.g. wireless routers, wireless mice, cordless telephones, microwave ovens, Bluetooth®, etc.  see the following Wikipedia article http://en.wikipedia.org/wiki/Electromagnetic_interference_at_2.4_GHz).  This additional noise can compound the issue of an improper installation of radios (i.e. not in line of sight or server radio mounted inside building) causing communication failure.
  • It is possible that over time that a wireless device's transmission power might decrease.  Nevertheless, it can be very difficult to determine whether there is actually an issue with a component (i.e. the radios) when an improper installation is present.  These comments relate not to just serial radios, but also Ethernet bridge radios (EBRs), and other types of wireless communication.
  • In other words, isolating an issue down to a component can sometimes be nearly impossible when radios are mounted/installed incorrectly.  The installation must sometimes first be resolved to determine if there is indeed an issue with a component.  The signal strength / link quality LED's can be helpful in determining a bad installation (low signal strength = likely bad installation).

KB ID: DD2098063


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