Venus 1500 V4: Receiving a Data Access Error "no process is on the other end of the pipe.", re-attach the database.

Potential Symptoms

  • When connecting to display getting an alert Data Access Error.
  • Alert: Data Access Error: A transport-level error has occurred when sending the request to the server.(provider: Shared Memory Provider, error:0 - No Process is on the other end of the pipe.)
  • May get a nucleus service error when launching Venus, with this alert in the error log or event viewer.

Environment

  • Venus 1500 V4
  • Windows XP, Vista, & 7

Cause

  • Database became corrupted on new PC or when upgrading from one Windows Version to another (Vista to 7); Or if updating Venus to a newer version (4.9 to 4.20.4).

Resolution

Option 1:
     Step 1: Stop the Daktronics Nucleus Server by following: How do I start, restart, or stop the V4 or SCS supporting computer services?
     Step 2: Detaching and Re-Attaching the Database

  1. Go to https://dakfiles.daktronics.com/ .
  2. Go to the following directory: Venus1500 -> Utils -> Nucleus Database Diagnostics
  3. Click and Download the Nucleus Database Diagnostics.zip file.
  4. Click Open, drag and drop folder contents to computer Desktop.
  5. Double-click the Nucleus Database Diagnostics Application file.
  6. After retrieving status, either click Repair or Detach.
    • If clicking Detach, now click Attach.
  7. Close Nucleus Database Diagnostics.

     Step 3: Start the Daktronics Nucleus Server by following How do I start, restart, or stop the V4 or SCS supporting computer services? .
Option 2:
Transfer the Database from the old PC to the new PC.

  1. Follow: How to uninstall Venus 1500 V4 on how to transfer database.

Option 3:
Start with a fresh/clean/new database.

Please note this process will wipe out the entire database including display configurations, presentations and schedules. Only do this if there is no messages/displays configured. Once you wipe out the database, there is no way to obtain a deleted/wiped database back.

  1. Go to the following location:
    • 32 Bit - C:\Program Files\Daktronics\Nucleus Server\Database Utility
    • 64 Bit - C:\Program Files (x86)\Daktronics\Nucleus Server\Database Utility
  2. Double-click and launch Database Utility.
  3. Click New: Clear current database to wipe or delete the database.
  4. Click Yes at the 'Do you want to save the existing database before proceeding with New Setup?'.
  5. Browse to save the current database backup on the local computer.

KB ID: DD2078703


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