Unable to Connect to Galaxy Display using a USB Adapter, Adapter not Showing up in Device Manager

Potential Symptoms

  • Unable to connect to display using adapter.
  • Adapter may not be recognized in Device manager.
  • Reseating the adapter in the same USB port yields no change.

Ethernet Adapter

  • Ethernet adapter is not under network connections.
  • Adapter is not under Network adapters in device manager even though the driver has been installed.
  • Light on adapter may or may not be on.

Serial Adapter

  • Adapter is not under Ports (Com & LPT) in device manager even though the driver has been installed.
  • Venus 1500 v3 symptoms:
    • Progress window flashes quickly when trying to Get Status to display.
    • When trying to communicate or get status, display name will turn red in display list (Error -12, unable to open communication port).
    • Memory Full error may occur when trying to send content to the display.
  • Venus 1500 v4 symptoms
    • May receive an alert: "Connect failed" or "No Response" (alert will appear immediately upon trying to connect).

Environment

  • Product Family: Message Displays
  • Product: Message Displays
  • Component: D-Link USB to Ethernet adapter, Prolific USB to Serial adapter, MOXA USB to Serial adapter
    • Note: Any general Ethernet or serial adapter may apply.
  • Control System: Device Manager, Venus 1500

Cause

  • Failed/bad USB port on computer.

Resolution

  1. Plug the adapter into another USB port.
  2. Then change the Com port in the Venus 1500 software to match what is being used in Device manager.  See How do I check that the COM port I am using is the correct one for my Venus 1500 software?, DD1999396 for details.

KB ID: DD2055459


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