Media Library is not showing thumbnails for the Animations and giving an error "The video could not be opened due to a missing codec or the codec was not properly installed."

Potential Symptoms

  • Media Library is not showing video thumbnails and giving error "The video could not be opened due to a missing codec or the codec was not properly installed."
  • Unable to edit video content.
  • Cannot save changes to existing videos.
  • Videos do not show up in Media Library.
  • Importing Video/Animations crashes Content Studio
  • Error in Content Studio: Handled COMException  System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
       at DexterLib.IMediaDet.get_StreamMediaType()
       at Daktronics.ContentCreation.Video.DirectShow.MediaDetector.OpenVideoStream(String videoFile)
       at Daktronics.ContentCreation.Video.DirectShow.MediaDetector.Load(String filePath)

Error:
The video could not be opened due to a missing codec or the codec was not properly installed.


Environment

  • Venus 1500 Version 4 (V4) 
  • Content Studio
  • Windows 7 OS

Cause

  • DivX Plus Software 8.0 or Configuration DivX (XviD Codec, DivX Plus Codec Pack, DivX Plus Converter, DivX Plus Player and DivX HiQ + Web Player Beta) was installed recently on the PC (Or any other type of Video Codec Package of some type). The DivX or one of its components corrupted or causes confliction with our Content Studio. See image below for example. You can see DivX program was install only 4 days prior to our software being update. This helps indicate that was a change made before the software stopped working.



Resolution

  • Fully Uninstall DivX Plus Software 8.0 or any DivX program (XviD Codec, DivX Plus Codec Pack, DivX Plus Converter, DivX Plus Player and DivX HiQ + Web Player Beta)  and all its components. Other known programs to cause Issues: (LAV Filters), Hik_MFPlugins V6.2.1.2(Hikvision).
  1. Go to Windows Start Menu -> Control Panel -> Add/Remove Programs or Programs and Features.
  2. Browse and locate any program installed as DivX (Configuration DivX, Setup DivX, LAV Filters, etc.).
  3. Highlight program and click Remove/Uninstall.
  4. Follow through prompts and make sure to select ALL Installed Components.
  5. Continue through uninstall until you are able to click Finish.

KB ID: DD2047219


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.