Can't communicate with display, Prolific adapter not installed correctly.

Potential Symptoms

  • Messages are in stored and not running, display may be blank.
  • No communication to display.
  • Receiving a Venus alert error "Connect Failed"
  • When viewing device manager, the Prolific adapter is not listed under the Ports (COM &LPT) section but it is showing up as USB-Serial Adaptor in other Devices with yellow exclamation point.

Environment

  • Product Family: Message Displays
  • Product: Galaxy
  • Component: Original Prolific USB to serial adapter (Blue DB9 connector/cable)
  • Control System: Venus 1500 V3, Venus 1500 V4
     

Cause

  • USB to serial adapter or driver is not installed properly.

Resolution

Step 1: Get the driver online or off the CD that comes with the adapter.
  1. First step is to try plugging the USB adapter into another USB port on the computer (if driver was installed while adapter was plugged into computer, it only installs it for that specific port...if cable was plugged into incorrect port it will show up under USB-Serial Adapter in other Devices with a yellow exclamation point. If this does not resolve issue proceed to #2.
  2. Driver can be found at one of the following sites or on the CD (driver disk) that came with the Prolific adapter:
  3. Log-in to our Support webpage to download more files: http://www.prolific.com.tw/US/CustomerLogin.aspx
    • Account: GUEST
    • Password: GUEST
Step 2: Installation of the driver.
  1. Remove any previous driver software from computer.
  2. Reboot computer.
  3. Locate the correct driver for USB adaptor depending on PC operating system.
  4. Have USB to serial adapter unplugged from the computer at this time.
  5. Open the PL2303 Prolific DriverInstaller Setup.exe and follow the steps to install the driver, the installer will tell you when it is ok to plug in the adapter.
  6. Make sure Prolific USB to serial adapter is recognized in Device manager.
Step 3: Verify com port driver is using and setting up the Venus 1500 software.
  • Configure correct com port number in Venus 1500 software with com port in Device manager when plugged in.

KB ID: DD1991159


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