DakStats: software citing “Software Protection Failed” Error Message

Potential Symptoms

  • The DakStats program has been unlocked with a valid registration code, or does not have an expired trial period (30 days).
  • This is a new installation of DakStats on this computer.
When attempting to open the DakStats program, the following error message appears: Software Protection failed. Please contact your DakStats software provider to obtain a registered copy of the software!

Environment

  • Product: DakStats
  • Component: 
  • Control System:

Cause

  1. Are you running Windows Vista or Windows 7? See Resolution 1.
  2. Are you running Windows Vista, Windows 7, or Windows 8.1 and have already registered the software? See Resolution 2.
  3. Does your IT department typically require administrative rights to install programs? See Resolution 3.
  4. Did you change the date on the computer? See Resolution 4.

Resolution

Resolution 1:

If the customer is using Windows Vista or Windows 7, the software needs to be registered differently:
  1. Right-click the DakStats icon on the desktop. 
  2. Click Run As Administrator.
  3. Go to Help > Register
  4. Register online with the information supplied by Daktronics or send the serial number and version to dakstats@daktronics.com
  5. Once registration is complete, close the program and open it as usual. Login in as an administrator only need to be done when registering. 

Resolution 2:

If the customer is running Windows Vista or Windows 7, and have already registered the software but are still receiving this error message, tell them to completely shut down (not restart) the computer, then turn it back on. Once the computer has rebooted, open the software with the right-click run as administrator resolution.

Resolution 3:

Registry disclaimer
Important
: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:


How to back up and restore the registry in Windows
Search Microsoft support for this article:  How to back up and restore the registry in Windows - Windows 7 Windows 8.1 Windows 10

Tell the customer to have their IT Department ensure they have, at the very least, read, write, and delete permissions in the "C:\Program Files\Daktronics" folder and its subfolders and "C:\Daktronics" and its subfolders.  Full permissions to the following registry key are also necessary: "HKEY_LOCAL_MACHINE\SOFTWARE\Daktronics"

To change these on Windows 7 right click on the folder and go to Properties. From there go to the Security tab. Click Edit and then Add. Type in Everyone and click Check Names. Select Everyone from the list and check Full Permissions. Click Apply then OK.

Resolution 4:

If the date on the computer was changed, DakStats can interpret this as tampering with the software protection. Registering the software removes this error message. Reinstalling the software from www.dakstats.com will also reset the software protection. 
 

KB ID: DD1581582


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