When starting Daktronics Nucleus Service manually, it starts and stops automatically and get error: Cannot open database "Nucleus Database" requested by the login. The login failed"

Potential Symptoms

  • When launching Venus 1500 v4, receive a Nucleus Error.
  • When starting Daktronics Nucleus Service manually, it starts and stops automatically.
  • When viewing Nucleus Error logs, receive the following error:
    • Cannot open database "Nucleus Database" requested by the login. The login failed
  • In Nucleus Server System.log file, the following error is present:
    • Message: Error refreshing modems.
      Category: Nucleus, System
      Severity: Error 
      Exception: System.Data.SqlClient.SqlException (0x80131904): Cannot open database "Nucleus Database" requested by the login. The login failed.
      Login failed for user 'NT AUTHORITY\SYSTEM'.
    • Message: Failed to establish connection to Nucleus Database after 120 seconds. Cannot open database "Nucleus Database" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\SYSTEMS'.
  • Display Studio Error - Object reference not set to an instance of an object.

Environment

  • Product Family: Software
  • Product:
  • Component:
  • Control System: Venus 1500 V4, Display Studio

Cause

  • The database is detached from SQL.

Resolution

  1. Run the Nucleus Database Diagnostics Utility.
    1. Go to the following web location:
    2. Save As, and save ZIP File to the Desktop.
    3. Right-click the Nucleus Database Diagnostics.zip and choose Extract all
    4. Click Finish or Next
    5. Double-click and run the Nucleus Database Diagnostics utility
    6. Click Repair next to any databases that are labeled as Offline or Click on Attach next to any database that is labeled as detached
    7. Once they say attached, close Nucleus Database Diagnostics utility.
      • If you receive an 'Access Denied Error' when trying to click Repair, see the workaround below.
  2. Restart the SQL and Daktronics services.

For Temporary Operation

Option 1:

  • Run the Nucleus Database Utility and restore the Database to the current automatic database backup file.
    1. Go to the following location to locate the backup database file (Backup.nucbak):

      • Windows 32 Bit System: C:\Program Files\Daktronics\Nucleus Server\Backup
      • Windows 64 Bit System: C:\Program Files (x86)\Daktronics\Nucleus Server\Backup
    2. Use the Nucleus Database Utility to load the auto backed up database to the new computer.

Option 2:

  • Run the Nucleus Database Utility and restore the Database to a New Database.
    • Warning: Only perform the following only if there is no stored displays, presentations and schedules, or if the user is ok with losing all previous data. (Work around option 1 should be tried first.)
If you have a large database and many presentations you wish not to lose, please contact Daktronics Technical Support to see if any other options are available.

KB ID: DD2557914


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