When starting Daktronics Nucleus Service manually, it starts and stops automatically and get error: Cannot open database "Nucleus Database" requested by the login. The login failed"
Potential Symptoms
- When launching Venus 1500 v4, receive a Nucleus Error.
- When starting Daktronics Nucleus Service manually, it starts and stops automatically.
- When viewing Nucleus Error logs, receive the following error:
- Cannot open database "Nucleus Database" requested by the login. The login failed
- In Nucleus Server System.log file, the following error is present:
- Message: Error refreshing modems.
Category: Nucleus, System
Severity: Error
Exception: System.Data.SqlClient.SqlException (0x80131904): Cannot open database "Nucleus Database" requested by the login. The login failed.
Login failed for user 'NT AUTHORITY\SYSTEM'. - Message: Failed to establish connection to Nucleus Database after 120 seconds. Cannot open database "Nucleus Database" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\SYSTEMS'.
- Display Studio Error - Object reference not set to an instance of an object.
Environment
- Product Family: Software
- Product:
- Component:
- Control System: Venus 1500 V4, Display Studio
Cause
- The database is detached from SQL.
Resolution
-
Run the Nucleus Database Diagnostics Utility.
-
Go to the following web location:
- Save As, and save ZIP File to the Desktop.
- Right-click the Nucleus Database Diagnostics.zip and choose Extract all
- Click Finish or Next
- Double-click and run the Nucleus Database Diagnostics utility
- Click Repair next to any databases that are labeled as Offline or Click on Attach next to any database that is labeled as detached
- Once they say attached, close Nucleus Database Diagnostics utility.
-
- If you receive an 'Access Denied Error' when trying to click Repair, see the workaround below.
-
- Restart the SQL and Daktronics services.
For Temporary Operation
Option 1:
- Run the Nucleus Database Utility and restore the Database to the current automatic database backup file.
-
Go to the following location to locate the backup database file (Backup.nucbak):
- Windows 32 Bit System: C:\Program Files\Daktronics\Nucleus Server\Backup
- Windows 64 Bit System: C:\Program Files (x86)\Daktronics\Nucleus Server\Backup
- Use the Nucleus Database Utility to load the auto backed up database to the new computer.
- For Venus 1500 v4, follow How do I start, restart, or stop the V4 or SCS supporting computer services? to load the backed up database to a new computer.
-
Option 2:
- Run the Nucleus Database Utility and restore the Database to a New Database.
- Warning: Only perform the following only if there is no stored displays, presentations and schedules, or if the user is ok with losing all previous data. (Work around option 1 should be tried first.)
- Once the action is completed, there is no possible way to reverse the changes made.
- For Venus 1500 v4, follow Venus 1500: How to uninstall version 4 .
KB ID: DD2557914
DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.
DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.
The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.