Receiving error 5023 when trying to start or restart the Microsoft SQL Server 2005, 2008, and 2014 SP2 for Venus 1500 v4

Potential Symptoms

  • When restarting SQL Service, get the following error:
    • Windows could not start the SQL Server (NUCLEUS) on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 5023.
  • When checking either Event Viewer or the Microsoft SQL Server Error Log see the following errors:
    • Error Log Location:
      • 32 bit OS: C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG
      • 64 bit OS: C:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\LOG
    • Errors:
      • The server was unable to initialize encryption because of a problem with a security library. The security library may be missing. Verify that security.dll exists on the system.
      • TDSSNIClient initialization failed with error 0x139f, status code 0x80.
      • TDSSNIClient initialization failed with error 0x139f, status code 0x1.
      • Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.
      • SQL Server could not spawn FRunCM thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.

Environment

  • Product:
  • Component:  Microsoft SQL Server 2005, Microsoft SQL Server 2008, Microsoft SQL Server 2014 SP2
  • Control System: Venus 1500 v4

Cause

  • The security.dll or secur32.dll files are either missing from the Windows System folder located at C:\Windows\System32 folder or have been come corrupted.

Resolution

Windows Vista & Windows 7, Windows 10

  • Run a sfc /scannow to do a system file check.
  1. Go to Windows Start Menu, in Search Programs or Search Programs and Files type CMD.
  2. Right-click on the CMD that filters in the Start Menu and choose Run as Administrator.
  3. Type in the following command and hit [Enter]: sfc /scannow
  4. Allow scan to complete.

Windows XP

  • Run a sfc Scan to do a system file check. This does require the Original Windows Operating System Disk to perform.
  1. Insert Windows Operating System disk into the disk drive.
  2. Go to Windows Start Menu, click Run.
  3. In the Run window type CMD and hit [Enter].
  4. Type in the following command and hit [Enter]: sfc /scannow
  5. Allow scan to complete.

For Temporary Operation

IMPORTANT: It is recommend for User to contact their IT Department on site perform these steps, since the steps are dealing with sensitive Operating System files. Steps should not be performed by any Daktronics Support Technician. We also do not support or troubleshoot if the workaround does not fix or breaks the computer. 

  1. Go to Windows Start Menu, choose Computer or My Computer.
  2. Navigate to the Windows System folder typically located at the following location:
    • C:\Windows\System32
  3. Locate and Rename the secur32.dll and security.dll files
    • Example: secur32_original and security original
  4. In a new Windows Explorer window, navigate to the following folder location:
    •  C:\Windows\$NtServicePackUnistall$
  5. Locate the security.dll and secur32.dll files, right-click and choose Copy.
  6. Go back to the Windows System32 Folder, right-click in open area of folder and choose Paste.
  7. Restart the computer.
    •  The computer may go through some systems checks upon restart.
  8. Launch the Venus software and see if issues are resolved.
If neither the resolution or workaround resolves the issue, either a System Restore or a Reformatting of the Windows Operating system may be required.

KB ID: DD2468375


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