Content Studio: When saving presentation, receive error "Failed to save the presentation because of an unexpected error. See log file for the error details.", Improperly mapped folder.
Potential Symptoms
- When in the Open Presentation prompt and trying to select My Documents, receive the following error: "The path is not of legal form."
- Receiving error when trying to save presentation in Content Studio: "The folder cannot be accessed. Verify you do not have a network connectivity issue if the folder is on your network and you have security permissions to the folder".
- Checking error logs shows: "System.UriFormatException: Invalid URI: The URI is empty."
Environment
- Product Family: Software
- Product:
- Component: Content Studio
- Control System: Venus 1500 v4, Show Control, Display Studio
Cause
- My Documents folder is mapped to another location on the computer or server that is not currently available. Because there is no connectivity to that drive or location, you are unable to save a new presentation or existing. The Nucleus file dialog can not handle this scenario and will close Venus 1500 v4.
How to diagnose:
Option 1:
- Open a Presentation in Content Studio.
-
From the Open window, try and select My Documents, My Computer and any other available location.
-
If it gives any of the errors, there is a mapping issue, proceed to resolution.
- Access Denied.
- The path is not of legal form.
Option 2:
- Go to Windows Start Menu, click on My Documents.
- If you get an error or the My Documents do not open, there is a mapping issue, proceed to resolution.
Option 3:
WINDOWS XP
- Go to Windows Start Menu, right-click on My Documents, go to Properties and verify the Target location.
- Make sure you can navigate to the path listed in the Target folder location.
- If unable to, there is mapping issues, proceed to resolution.
- If somewhere other then the default location, this can cause issue for Venus 1500 v4.17 or earlier.
WINDOWS 7
-
Windows 7 go to Windows button, right click on Documents, Click Properties. Should look like picture on the left. If it looks like the one on the right it is not using C drive and one of the shared drives is most likely disconnected.
WINDOWS 10
In Windows 10, go to Windows button and right click on documents folder, go to properties.
Here you will see if mapping is correct or not.
1. If it is mapped correctly, you will see My Documents:, if not you will see a public folder or another folder.
2. If it is mapped incorrectly you will see no My Document folder and a public folder or a different folder. The my Document folder will be incorrectly mapped and disconnected.
Resolution
- Update the software to most recent version of Venus 1500 v4.
- If update has an error, repair Venus 1500 V4 and then update.
- If issue remains user will need to contact their Network Administrator, IT Department or a Computer technician to restore proper access to the My Documents folder location or default location.
Note: Venus 1500 v4.18 and above are able to handle My Documents being stored in a different location than the default. Local IT can reference: Failed to save the presentation because of an unexpected error: registry values set incorrectly if mapping My Documents back to the original location does not work.
KB ID: DD2259773
DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.
DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.
The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.