Venus 1500 prompting for .NET Framework update

Potential Symptoms

  • Recently updated Venus 1500 v4.
  • When launching Venus 1500, getting error "This application requires one of the following versions of the .NET Framework: .NET Framework, Version=4.6.1."
  • When trying to update .NET Framework, receiving message "The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2."
  • Windows Updates are not set to install automatically.
  • Windows Updates shows many updates available.

Environment

  • Product Family: Software
  • Product: Galaxy
  • Component: .NET Framework on Windows 8.1 or Windows Server 2012 R2
  • Control System: Venus 1500 v4

Cause

  • The .NET Framework is not up to date and cannot run the current version of the Venus 1500 v4 software.

Resolution

  • If Windows is up to date:
    • Download and install .NET Framework 4.6.1 or greater.
  • If Windows is not up to date:
    • Install Windows updates until the suggested update is installed.
    • After Windows updates are installed, install .NET Framework 4.6.1 or greater.

KB ID: DD3806228


Fill out my online form.
DISCLAIMER: Use of this content may void the equipment warranty, please read this DISCLAIMER prior to performing any service of the equipment.