DMP-8122 inconsistent EDID emulation

Potential Symptoms

  • Combined desktop breaking after reboot.
  • 1 or more displays blank/no signal.
  • Set resolution reverting to Display native resolution

Environment

  • Product: LCD Networks, Digital Signage
  • Component: DMP-8122
  • Control System: Venus Control Suite

Cause

  • Compatibility issue between older BIOS and various Intel Video drivers
Note: EDID emulation is managed within the BIOS settings.
See: - Setup EDID Emulation on DMP-8122 for more information.

Resolution

  1. Stop the player from running before any update is ran.  System may lock-up if player software is not stopped.
    1. Stop DMP8000 App 
      1. Access the Daktronics folder via the Start menu and select DMP8000 Shutdown
  2. Verify current BIOS revision.
    1. On Player open the Start menu
    2. Type msinfo32 and press enter.
    3. Bios Version/Date
    4. Embedded Controller Version.
image.png
Note: As of 12/2023 - Updated versions are
BIOS: CCBWHL357.0103.2023.1013.1424, 10/13/2023 
Embedded Controller: 2.30
 
  1. Download the zip folder from Dakfiles
    • 8122 Update
    • Click on DMP8122_uprade.zip to download.
    • Once downloaded, navigate to folder and unzip.
  2. Update BIOS/EF Firmware (if required)
    • Navigate to un-zipped DMP122_upgrade folder.
    • Run CBWHL357.0103.EBU.exe
    • When prompted press Y and Enter to reboot the player.
    • This will take approximately 5 minutes and will reboot after its finished.
  3. Once the player reboots, check that both the BIOS and EC versions were updated.
    • Bios Version: 0103
    • Embedded Controller Version 2.30
  4. Run Windows Updates
    • Check for further updates after player reboots until there aren’t any further updates available.
  5. Install provided Intel Graphics Driver 
    • Navigate to the unzipped DMP8122_upgrade folder.
    • Unzip GFX-Win10_Win11-31.0.101.2114
    • Navigate to the unzip folder and run Installer.exe.
    • Agree to Intel’s Agreement
    • Click the checkbox to Execute a Clean install.
    • Click Start
    • Reboot player after installation is complete.
  6. Set display setting to desired settings.
  7. Reboot DMP Player
    • If prompted with a Persistent Emulation Display Alert, press b on the keyboard. This can only be done with a keyboard connected directly to the player.


 

KB ID: 000027552


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.