Data Server: Why does my clock time triggers fail occasionally when under a minute?
Potential Symptoms
Environment
Product: Data Server
Components: Automated data triggers
Control System:
Cause
1. Some clock times shift in the ERTD stream depending on hours, minutes and seconds left (see fields 1 and 3 before and after the 1 minute mark):
2. All Sport clocks update every tenth of a second when under the 1 minute mark. Complex trigger logic can take longer than a tenth of a second to evaluate all of the conditions and branches. The data can't be updated while conditions are being evaluated, so ERTD changes get put into a queue for triggering logic to run against. To avoid risk of evaluating old data that has been in the queue for a while (when data is received faster than processed) the queue size has been set to 1 so the latest data replaces the currently queued data ensuring the next iteration of triggering logic runs against the most current data.
Because of this, while evaluation of a packet containing "0:50.1" the packet with "0:50.0" may be skipped because "0:49.9" arrived prior to 50.1 completing its work. So if a condition checking for Clock = "0:50.0" could fail to trigger.
3. Other causes:
- UDP packets are not guaranteed delivery, especially in control rooms with an old or poor network setup under heavy load, and therefore triggering may not always receive an ERTD packet containing a specific value you're looking for, like "11:00.0".
- An old computer may not have the memory and processing power to handle running logic at tenth of a second speeds.
- If you have a lot of triggers and a complex set up, there may be a point where you cannot keep up with data coming in every tenth of a second.
Resolution
Note: Be aware that leading and trailing spaces are removed from data fields prior to comparing against your custom field.
2. My clock time trigger still fails under a minute and I'm using fields that don't shift the minutes values within the ERTD.
All Sport clocks update every tenth of a second when under the 1 minute mark. Complex trigger logic can take longer than a tenth of a second to evaluate all of the conditions and branches. The data can't be updated while conditions are being evaluated, so ERTD changes get put into a queue for triggering logic to run against. To avoid risk of evaluating old data that has been in the queue for a while (when data is received faster than processed) the queue size has been set to 1 so the latest data replaces the currently queued data ensuring the next iteration of triggering logic runs against the most current data.
Because of this, while evaluation of a packet containing "0:50.1" the packet with "0:50.0" may be skipped because "0:49.9" arrived prior to 50.1 completing its work. So if a condition checking for Clock = "0:50.0" could fail to trigger.
A variety of things can be done to make triggers more efficient.
- Consider using a custom DID to break data fields into parts that don't change as oftens. i.e. create a Minutes field and Seconds field (or Seconds Tens-Digit field). This allows you to wrap your trigger into a 'Changes' trigger that can exit out early if the minutes value of the clock doesn't change and avoid evaluating all of the conditions every second or tenth of a second. Note: Custom DIDs should only be imported into and used by Data Server (not Content Studio or anywhere else)
- Set the SubTriggers to 'First' instead of 'All' on every parent trigger that should only have one of its sub triggers fire. This allows the logic to exit early and not continue to check all of the other sub triggers every time. For the example above, if the clock time changes to 5:24, it will play the content 500-559 on sign 11 and exit without checking for Clock Minutes = 4, 3, 2, 1 or 0. If SubTriggers was set to 'All' (as is by default) it would run through all of those checks even though we know they won't be true.
- When using SubTriggers set to 'First', order the conditions such that the most common is listed first and the least common is listed last to exit out early more often.
- The same set of triggers can be defined multiple ways, and with some thought you can simplify the number of checks (even though it's not always intuitive). The following triggers are identical in behavior but the second requires less logic:
3. Other resolutions:
- Consider an analysis of your system's network to ensure it isn't having issues with dropped or delayed UDP packets. There are some techniques to help improve the performance of your network if this is the case.
- Consider computer or network upgrades if you have an older system that is struggling to keep up.
- Consider Simplifying/Removing unnecessary triggers to reduce stress on the system.
KB ID: 000019770
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