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1	 Introduction
The purpose of this manual is to assist with the installation and operation of the Daktronics 
StatVision™ for Baseball application. 

The manual includes the following main sections: 

•	 Introduction covers the basic information about the program and this manual. 
Take time to read the introduction as it defines terms and explains concepts used 
throughout the manual. 

•	 Installation describes the software installation procedures. 

•	 Setup explains the necessary configurations to gather and output Real-Time Data 
(RTD).

•	 Pregame Operation and In-game Operation detail the specific operation of the 
software. 

•	 Appendix contains information pertaining to specific protocols and setting up display 
sequences. 

Software Overview
StatVision significantly reduces pre-game preparation by instantly analyzing the large 
amounts of data from sources such as DakStats, MLB.com, and Elias Sports Bureau. The 
data is pulled up in easy to use categories (Figure 1). Positive categories are highlighted 
for the operator and can be sent to a display with the press of a button.

Figure 1: StatVision Main Application Screen
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The StatVision program gathers data from other software and presents it in a way that is 
easy to select what to display. Below is a diagram of how the many pieces fit together.

1.	 GameDay downloads the latest stats and standings and creates the day’s game in 
DakStats.

2.	 DakStats sends game-in-progress (GIP) data to the Daktronics Scoring-Timing 
Interface (DSTI), which in turn is sent to StatVision. 

3.	 StatVision displays the GIP data from DakStats and can request more detailed 
statistics based on the current situation from a shared database. StatVision sends this 
data and various control commands to the Daktronics display controller. 

* Typically located on a separate computer from StatVision, but on the same network

Note: DMP-7000 refers to a Venus® 7000 player that is being used as part of an 
integrated Show Control System. Some features/functions described in this 
manual are specific to the Venus 7000 player outside of Show Control at this 
time and are noted as such. DMP-8000 refers to a V-Net® player as part of an 
integrated Show Control System. 

Software Requirements
•	 Microsoft Windows® XP/Vista/7 or higher Operating System

•	 CPU and RAM must at least be equal to minimum requirements of operating system

•	 Additional serial ports/networking may be needed based on interface requirements 

Software Conventions
This manual contains the following software conventions and terminology: 

Bold
Indicates an item that requires direct action, such as clicking, pressing, 
selecting, or formatting. Also used for reference items within the manual, 
such as figures or sections, as well as other documents and notes. 

Italics Indicates onscreen text or labels that are not clickable. 

[Brackets] Represents a keyboard key that needs to be pressed. 

“Quotes” Text or commands that may be typed. Quotes also indicate folder names. 

Click Press and release the left mouse button. 

Double-click Press and release the left mouse button twice. 

Right-click Press and release the right mouse button. 

Select Highlight or mark, such as by placing a check mark in a nearby box; 
clicking will not necessarily perform an action. 

> Followed by (example: File > Open). 
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2	 Installation

Downloading from the Internet
1.	 Download the StatVision program. 

a.	 Open an Internet browser and go to http://dakfiles.daktronics.com/downloads/
Sports_Products/StatVision/

b.	 Click on the “StatVision Install.exe” file. 

c.	 In the window that appears, click Run. If an additional window opens, click Run 
once more. 

2.	 Follow the on-screen instructions. 

3.	 Click Finish when done. 

4.	 Repeat Steps 1-3 on each computer that must have StatVision 
installed. The “StatVision Install.exe” file may be downloaded and 
saved to be transferred to other computers without Internet access.

5.	 Double-click the desktop icon (Figure 2) to open the program.*

*Note for Windows 7 users: it will be necessary to run the program as an administrator 
to operate correctly. Right-click the desktop icon and select Properties. Click on  
the Compatibility tab, and ensure Run this program as an administrator is checked. 
Be sure to also do this for DakStats, DSTI, and GameDay for best compatibility. 

Installation Checklist
  Download StatVision
  Set up DakStats messaging and share folder
  Set up DakStats database connection
  Set up signs
  Create sequences
  Set up sequence names
  Test sequences
  Edit category titles if necessary

Figure 2: Icon

http://dakfiles.daktronics.com/downloads/Sports_Products/StatVision/
http://dakfiles.daktronics.com/downloads/Sports_Products/StatVision/


Setup
4

3	 Setup
After installing StatVision, four steps are necessary to set up the software for the first time:

1.	 Set Up DakStats (p.4) – Specifies the messaging between StatVision and DakStats

2.	 Set Up Data Configuration (p.4) – Specifies the location of the DakStats database.

3.	 Set Up Signs (p.5) – Specifies which signs will be controlled by StatVision.

4.	 Set Up Sequences (p.6) – Specifies sequences that StatVision will tell the display 
controller to play.

5.	 Game Day Setup (p.9) – Describes setup steps to perform before each game.

Set Up DakStats
For StatVision to work correctly with DakStats Baseball, the operator must set up 
messaging and share the folder.

Set Up Messaging
1.	 In the DakStats Baseball program, go to Configure > Messaging. 

2.	 Ensure Different Machine (IP Network Messaging) is selected if DakStats is on a 
different computer than StatVision (most common).

3.	 Click OK.

Sharing the Daktronics Folder
If the DakStats and StatVision programs are on different computers, the directory where 
the DakStats database is located must be shared:

1.	 Go to the computer with the DakStats program.

2.	 Browse to the “C:\Daktronics” directory.

3.	 Right-click the folder.

4.	 Select Sharing and Security.

5.	 Share the folder with full permissions.

*Note for Windows 7 users: After right-clicking the folder, select Properties, and click on 
the Sharing tab. Click on Advanced Sharing, select Share this folder, and click OK.

Set Up Data Configuration
Note: Open a demo game in DakStats before performing the following steps.

1.	 Open StatVision.

2.	 Go to Edit > Data Configuration.

3.	 In the Data Configuration window 
(Figure 3), click the […] button.

4.	 Locate the “Baseball” folder within 
the “Daktronics” folder that was just 
shared on the DakStats computer 
as described in Set Up DakStats (p.4). 

5.	 Click OK to save the data configuration. 

Figure 3: Data Configuration



Setup
5

Set Up Signs
Sign configuration allows the operator to configure the display that StatVision will control 
and send information to. At least one sign must be configured. 

Configuring Signs
1.	 Open the Daktronics Scoring-Timing Interface (DSTI), if not already running, by 

double-clicking the DSTI icon on the desktop. 

•	 DSTI is typically installed on the same computer as DakStats.

•	 The RTD ports available in StatVision are configured in DSTI by Daktronics.

2.	 Open StatVision, either on the same computer as DSTI or on a separate computer. 

3.	 Go to Edit > Signs, and the Sign Configuration window will appear (Figure 4).

Figure 4: Sign Configuration

4.	 In the Sign Name column, enter a descriptive name for the sign. The name of the sign 
can be anything that makes sense to the operator.

5.	 In the Sign # column, select the sign number of the sign that StatVision will control.

To check the sign number in Venus 7000:

a.	 On the Venus 7000 computer, open the Venus 7000 Shell.

b.	 Go to Configure > Signs.

c.	 Double-click the desired sign, and go to the Advanced tab.

To check the sign number in V-Net:
a.	 On the V-Net computer, right-click the V-Net Manager icon in the task bar ( ) 

and select Control Panel.

b.	 Click on the Edit Configuration Settings tab.

Note: If the sign number is 0, change it to any number that is not already being 
used. If multiple signs are set to 0, the same data and commands will be sent 
to every sign on the network configured with that sign number.

6.	 In the Display Port column, select the port to be used for the sign from a list of 
available ports supplied by DSTI.

Note: A display port can only be selected once. If more than two signs are 
controlled, contact Daktronics to have the DSTI configuration file modified.
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7.	 Use the Drives column to select the drive letter(s) 
where content is stored for the selected sign. In the 
Drive Letter Configuration window (Figure 5) type in 
a new drive letter (if different from the default “D” 
drive) and click Add. Click OK when finished.

8.	 If using a V-Net controller, be sure to click in the 
Control Port column and then click Yes. This will send 
display commands over a specific port.

9.	 Click OK to save the sign.

Checking Signs
After a sign has been configured, it appears as a button 
on the top of the screen (Figure 6).

Figure 6: Checking Signs

•	 Click a sign once to enable it. Enabled signs are highlighted in green.

•	 Click a sign again to turn it off. Disabled signs are highlighted in red.

•	 If a sign has more than one drive letter assigned, there will be a different button for 
each sign and drive letter combination.

Note: More than one sign may be checked at a time, and at least one sign must be 
checked to output stats/messages. Standings/leaders can be displayed without 
any signs checked. 

Set Up Sequences
When a certain combination of stats is to be displayed, StatVision tells the display 
controller to play a sequence that matches the selected data. The Sequence 
Configuration window is where the names of these sequences are specified. 

Note: At a minimum, there must be a sequence for 1 Category/3 Stats and 1 
Category/4 Stats. It is not necessary to create sequences for every possible 
category/stat combination. 

Creating Sequences
Sequences are built on the Venus 7000 or Show Control computer. They determine the 
layout of the statistics and standings on the sign, including how many and what statistics 
are to be displayed. Separate sequences are required to display leaders and standings. 
Refer to Appendix A for further assistance with creating display sequences. 

Figure 5: Drive Letter Configuration
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Use the following table to determine what input template file (ITF) or Data Interface 
Definition (DID) file to use for each type of data that StatVision sends out:

Data Type ITF/ DID File Dynamic Data Library Folder
Fixed, Situational, & Non-
updating Stats StatVision Stats StatVision Stats

League Leaders StatVision Leaders StatVision Leaders

Standings StatVision Standings StatVision Standings

Player & Quick Messages DSTI DSBA Plr Msg req Requested: Player Messages

Elias Messages StatVision Elias Message StatVision Messages

Setting Up In-game Sequences
By default, double-clicking the Fixed or Situational Categories will make StatVision play 
1 Category and 3 Stats (AVG, HR, and RBI) for Batter information and 1 Category and 4 
Stats (ERA, IP, BB, and K) for Pitcher information. Operators must set up at least these two 
sequences.

1.	 Go to Edit > Sequences, and the Sequence Configuration screen will appear 
(Figure 7). 

2.	 Type in the file name of each desired sequence into the table as named on the 
Venus 7000 or V-Net computer.

Note: Any file name may be used for the sequences, but it is recommended to use 
names such as “1_3” for simplicity.

Figure 7: Sequence Configuration - In-game
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The fields on the In-game tab of the Sequence Configuration window are described in 
the following table:

Home Library & 
Guest Library

The library name indicates the library/folder where the StatVision 
sequences are stored. There is one library for the Home team and one 
library for the Guest team. If the same sequences will be used for the 
Home and Guest teams, enter the same library name. Having separate 
libraries allows sequences for each team with a unique appearance (for 
example, a team logo as the background).

Default If a Default sequence is entered, StatVision will automatically play this 
sequence when the batter/pitcher changes.

Player Message Under Sequence in the Player Message row, enter the name of the 
sequence to use for player messages.

Quick Message Under Sequence in the Quick Message row, enter the name of the 
sequence to use for quick messages.

Elias Message Under Sequence in the Elias Message row, enter the name of the 
sequence to use for messages from Elias.

Stat/Category Table Enter the names of each sequence for every category and statistic 
combination that will be used.

Note: If configuring multiple signs, the sequences must have the exact same names 
and be in a library with the same name for each sign.

Setting Up Pregame Sequences
The pregame sequences control how to display league leaders and standings. 

1.	 Go to Edit > Sequences. 

2.	 In the Sequence Configuration window, click the Pregame tab (Figure 8). 

3.	 Type in the appropriate names for the Libraries and Sequences. 

Figure 8: Sequence Configuration - Pregame
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The fields on the Pregame tab of the Sequence Configuration window are described in 
the following table:

Libraries

The library name indicates the library/folder where the StatVision 
sequences are stored. If the sequences reside in the same library for 
multiple leagues, the library name will need to be typed into each 
league. Having separate libraries allows sequences for each league with 
a unique appearance (for example, a league logo as the background).

Sequences

Indicates the sequences to be used for displaying Individual League 
Leaders, Standings, and Wildcard Standings. Wildcard Standings are 
separate from Division Standings because up to 13 teams are possible 
for Wildcard Standings, while only 6 are included in Division Standings.  
If the sequence for both is the same, the name will need to be entered 
in both rows. 

Leaders and standings sequences are displayed in pages. To configure how many stats 
to show per page and how long to display them, refer to Pregame Options (p.10).

Game Day Setup
Be sure to perform the following steps before every game:

1.	 Open the GameDay Baseball program and perform a successful download. 

2.	 Open DakStats Baseball and open the day’s game that GameDay created.

3.	 Ensure DSTI is open and communicating with DakStats.

4.	 Open StatVision and ensure the connection status 
indicators in the lower-right corner of StatVision 
are all green (Figure 9). 

Note: If all indicators are not green, refer to Section 8: Troubleshooting (p.32). 

For more information about the above programs, refer to the following manuals, which 
may be included in the software Help menu, downloaded from www.daktronics.com/
manuals, or requested from Daktronics:

•	 DakStats Baseball Software Operation Manual (DD1385420)

•	 DakStats Baseball Software Display Manual (DD1533474)

•	 Daktronics GameDay Baseball Software Operation Manual (ED-13979)

Figure 9: Connection Status

www.daktronics.com/manuals
www.daktronics.com/manuals
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4	 Pregame Operation
The Pregame tab (Figure 10) configures how and what league leaders and standings are 
displayed through playlists. By default, categories are highlighted in yellow for home and 
blue for visitors to see which stats are applicable to the two current teams. Operators can 
click on individual Stat categories and see the full details in the lower half of the screen.

Figure 10: Pregame Tab

Pregame Options
The pregame options are used to customize the leaders and standings output. 

1.	 Go to Pregame > Options (Figure 11). Note that the Pregame menu is only accessible 
while on the Pregame tab. 

Figure 11: Pregame Options
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2.	 Use this window to adjust the following options: 

Leaders

•	 Select the minimum rank that leaders must meet in order to be highlighted.  
This affects how stats appear in the user interface. 

•	 Choose to apply RTD Colors to leaders for the Home Team, the Guest Team, both 
teams, or neither team (Venus 7000 only). 

•	 Choose to show the top player from the home team if they would not normally 
be visible. For example, if an operator chooses to display the top ten leaders, 
but a player on the home team is in 17th place, this option would allow the 10th 
position to be replaced by that player instead. 

Standings

•	 Choose to apply RTD Colors to standings for the Home Team, the Guest Team, 
both teams, or neither team (Venus 7000 only). 

•	 Choose to show the home team in a specific spot of the wildcard standings if 
they would not normally be visible. For example, if an operator chooses to display 
only the top five teams, but the home team is in 7th place, this option would allow 
the 5th position to be replaced by the home team instead.

RTD Colors (Venus 7000 Only)

•	 Click Change to choose from 64 basic colors for the Home Team and Guest 
Team. Changing RTD colors will not affect the appearance of the user interface. 

Note: If a specific color is needed that is not selectable, contact Daktronics to 
customize the RTD color values.

3.	 Click OK to save the options. 

Creating Playlists
To display any of the information on the 
Pregame tab, operators must set up a 
playlist that defines what specific leaders 
and standings categories to show.

1.	 Go to Pregame > Add Playlist. 

2.	 In the Pregame Playlist Configuration 
window (Figure 12), type in a 
descriptive playlist Name. 

•	 Select the sign(s) to send the 
playlist to. Refer to Set Up Signs 
(p.5). Hold [Ctrl] while clicking 
to select more than one sign. 

•	 Enter the Hold Time in seconds for how long each page will remain on display. 

•	 Enter the number of Stat Categories per Page to display. Setting this to “2” would 
allow the operator to show AL and NL stat leaders at the same time. 

•	 Enter the number of Leaders to Show per Category at one time. 

Figure 12: Pregame Playlist Configuration
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3.	 Click OK, and the new playlist will appear in the Playlists section (Figure 13).

Figure 13: New Playlist

Note: Each additional playlist will have its own tab.

Adding League Leaders to a Playlist
Click in the space next to a Batting or Pitching stat category under the available league 
to mark it with a check. At the same time, the stat category will appear in the Playlist 
(Figure 14).

Figure 14: Adding League Leaders to a Playlist

Note: Alternately, click and drag the empty space where the checkmarks normally 
appear to the move stats to the desired position in the Playlist. 

Adding Standings to a Playlist
1.	 Click the Standings tab (Figure 15).

Figure 15: Standings Tab

2.	 Choose a League if necessary. 

3.	 Check the box(es) to add different division and wildcard standings to the Playlist. 

4.	 Click Extended to show a list of all available stats for the division and wildcard 
standings in the lower half of the screen. 
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If needed, click Edit to modify the standings. This allows standings to be updated 
immediately after the game is finished or if there was an error in the download process. 
In the Edit Standings window (Figure 16), click in the desired field to edit and type in the 
new value. Note that W% and GB are calculated fields and not editable. Click Save to 
keep the changes or Cancel to discard them.

Figure 16: Edit Standings

Affiliate Leaders & Standings
StatVision can display MLB leaders and 
standings for AAA, AA, A Advanced, A, A 
Short Season, and Rookie affiliates.

1.	 Close out of StatVision, DakStats 
Baseball, and DSTI if open.

2.	 Open GameDay Baseball.

3.	 Click on Configuration (Figure 17).

4.	 Select the League, Team, and Opponent (typically Automatic).

5.	 Enable Download MLB Standings/Leaders.

6.	 Click OK to save the changes. 

7.	 Slick Start to download the latest game and pregame files. 

8.	 Reopen DakStats Baseball, DSTI, and StatVision.

Back in StatVision on the Pregame tab, notice that in addition to the selected league, it’s 
now possible to enable AL and NL on the League Leaders tab, as well as select American 
League and National League on the Standings tab (Figure 18).

Figure 18: Leaders/Standings for MLB Affiliates

Figure 17: Download MLB Standings/Leaders
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Arranging & Removing Stat Categories
1.	 Select the leader or standing entry in the playlist.

2.	 Use the up and down arrow buttons to rearrange the order of the stats as needed, or 
simply click and drag them to the desired location. 

3.	 Click the trash can icon to remove the stat category. 

Note: Hold [Ctrl] while clicking to select and view, move, or delete multiple 
categories at the same time. 

4.	 As stat categories are added to the list, they get highlighted in alternating rows of 
gray and black according to the Categories/Page setting (Figure 19).

Figure 19: Playlist with Different Category/Page Values

The black arrows indicate what categories are currently being sent out. These arrows 
will move down to the next category (or categories) according to the Hold Time.

Editing Playlists
1.	 Select the tab for the playlist to be edited.

2.	 Go to Pregame > Edit Playlist and the Pregame Playlist Configuration window 
appears (Figure 12). Here any setting may be changed but the Name.

3.	 Click OK to save the settings. 

Copying Playlists
1.	 Select the tab for the playlist to be copied. 

2.	 Go to Pregame > Copy Playlist and the Pregame Playlist Configuration window 
appears (Figure 12).

3.	 Type in a new Name for the copied playlist, and then click OK. 

Deleting Playlists
1.	 Select the tab for the playlist to be deleted. 

2.	 Go to Pregame > Delete Playlist. 

3.	 Click Yes to confirm the deletion. 

Outputting Playlists
Leaders and standings are outputted by using StartPlaylist and StopPlaylist Script Buttons. 
Refer to Section 6: Preset Buttons (p.20) for more information on creating scripts and 
script buttons.
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5	 In-game Operation
Statistics are displayed under three main categories for batters (Figure 20) and for 
pitchers (Figure 21):
•	 Fixed Categories are always displayed no matter the player or the situation. 
•	 Situational Categories apply to the current game situation based on the GIP 

information received from DakStats Baseball. For example, if the batter is up with 
runners in scoring position and two outs, Career With 2 Outs & Scoring Pos. will be 
selectable only as long as that situation lasts. This ensures that the most relevant 
information is available. 

•	 Non-Updating categories are only valid before the players’ first at bat. Unlike the 
other two categories, these stats do not update throughout the game.

Double-clicking a category in the Fixed, Situational, or Non-updating list will send the 
statistics to a display controller that will display the stats on the sign according to the 
sequence setup.

Figure 20: Batting Statistics

Figure 21: Pitching Statistics
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Viewing Player Stats
StatVision automatically selects the current batter and pitcher, but there are several 
ways to select other players and view their stats at any time. 

Batter Modes
Operators can select from three different batter modes. StatVision automatically updates 
these modes as the batting order changes.

To select batter modes, click Last Batter, Current Batter, or Next Batter. The selected 
mode will be highlighted in green (Figure 22). 

Figure 22: Selecting Batters

Team Rosters
If the statistics of a player other than the last, current, or next 
batter are needed, StatVision lets operators search the team 
roster and bring up any other player’s statistics. The team 
roster will display all of the players and their numbers that are 
on the team’s roster for that particular game. 

The roster separates players into two categories: 

•	 The Bullpen lists only the team’s pitchers. 

•	 The Bench lists every player on the team. 

Note: If the bullpen list is empty, make sure that the 
players have their positions set to pitcher in the 
DakStats roster. 

To view a team roster:

1.	 Click the team’s logo, and the team’s roster will appear 
(Figure 23).

2.	 Select a player from the roster by clicking the player’s 
name. StatVision will display the selected player’s 
batting/pitching statistics in the Fixed and/or Situational 
Categories. 

Viewing Fielder Statistics
To view statistics about players that are currently playing on 
the field, running the bases, or batting, simply click the player’s 
name shown on the baseball diamond image (Figure 24).

Figure 23: Team Rosters

Figure 24: Selecting Fielders
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Selecting Stats for Display
There are three ways to output stats for display:

•	 Double-click a single category to quickly display the default stats.

•	 Use the Category Specifics window to select multiple categories to play at once.

•	 Create Stat Buttons to preview and send frequently used stats. Refer to Adding Stat 
Buttons (p.28). 

When a category is sent for a batter, the three statistics shown by default are: batter 
average (AVG), homeruns (HR), and runs batted in (RBI). When a category is checked for 
a pitcher, the four default statistics shown are: earned run average (ERA), innings pitched 
(IP), walks (BB), and strikeouts (K). 

Displaying Multiple Categories
Checking a Fixed or Situational category shows its available stats in the Category 
Specifics area. Up to ten statistics in three separate categories may be sent at a time. If a 
fourth category is selected, the first checked category in the list will be deselected. 

Make sure the proper sequence has been configured to display the desired number of 
statistics and categories. Refer to Set Up Sequences (p.6). 

Note: Non-updating stats do not appear in the Category Specifics window. Only one 
non-updating category with three stats may be displayed at a time. 

1.	 Check the box next to one or more categories from the Fixed or Situational lists.  
The categories appear in the Category Specifics area in the order they were clicked. 

2.	 Under Category Specifics, click the desired stats and the entire column will be 
highlighted (Figure 25). To deselect a statistic, click anywhere within the column. 

Figure 25: Category Specifics

3.	 When all of the desired stats are selected, click the play button   to display the 
stats. Only the categories that are checked will be sent.

4.	 To clear all the categories in the box, click the Clear Categories  button.

5.	 If desired, click the floppy disk icon  to save the setup as a Stat Button. Refer to 
Adding Stat Buttons (p.28).

Note: Click and drag column headers to change the default order of the stat columns.

Messages
StatVision provides three different types of messages: Player Messages, Quick Messages, 
and Elias Messages. Click the appropriate tab to create, view, and display the messages.

Note: Player and Quick Messages may both use the same display sequence. Elias 
Messages require a separate sequence to display correctly. Refer to Set Up 
Sequences (p.6).
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Player Messages
The Player Msg tab displays messages 
for the selected player (Figure 26). 

Note: Player messages may be 
added/edited/deleted in 
DakStats Baseball by going to 
Configure > Player Messages. 

Adding Player Messages
1.	 On the Player Msg tab, click the 

Add button. 

2.	 Type out the desired message in the Player Message Editor window (Figure 27). 

3.	 Click Save. 

Displaying Player Messages
On the Player Msg tab, simply double-click a message to display it. 

Editing Player Messages
1.	 On the Player Msg tab, select the 

message to edit, and then click the 
Edit button. 

2.	 Modify the message text in the 
Player Message Editor window 
(Figure 27). 

3.	 Click Save. 

•	 With Word Wrap checked, 
longer words are automatically 
pushed down to the next line. 

•	 Left, Center, and Right refer to 
the text alignment. 

Deleting Player Messages
On the Player Msg tab, there are two ways to delete messages. 

•	 Select a message to delete, and then click Delete. Click Yes to confirm.

•	 Click Delete All to remove every message for the selected player. Click Yes to 
confirm.

Note: These actions cannot be undone!

Figure 26: Player Message

Figure 27: Player Message Editor
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Quick Messages
The quick message option allows 
operators to create a brief message 
and send it to the display without first 
saving it to a specific player. 

On the Quick Msg tab (Figure 28), type 
in a message, and then click Send to 
display it. Click Clear to remove all text 
from the boxes. 

•	 With Word Wrap checked, longer 
words are automatically pushed 
down to the next line. 

•	 Left, Center, and Right refer to the 
text alignment. 

Elias Messages
Elias messages come directly from 
Elias Sports Bureau (ESB). Messages 
for the current batter and pitcher 
are displayed at the same time. Elias 
messages may not be edited before 
being sent to a display (Figure 29).

1.	 Click the Elias Msg (#) tab. The # 
will change depending how many 
messages are available for the 
current batter and pitcher. 

2.	 Double-click a message to display it. 

Figure 28: Quick Message

Figure 29: Elias Messages
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6	 Preset Buttons
Preset Buttons provide control over what data is sent to displays and how it is displayed.

•	 Script Buttons allow operators to display sequences other than just statistics. Display 
any sequence desired, blank the sign, and much more. Script Buttons eliminate the 
need to switch back and forth between StatVision and the display controller to use 
basic commands. 

Note: Only one button can be running at any time. If a button is pressed while 
another script is running, the script will stop before a new script may start.

•	 Stat Buttons allow operators to assign frequently used stats into convenient buttons. 
Stat Buttons may be predefined to display the same group of stats, or let the operator 
select certain stats just before being sent to a display. 

The Preset Buttons area is dockable, meaning it can be placed anywhere on the 
StatVision main screen, and re-docked on the screen’s border. To move the area, 
click on the words Preset Buttons, and drag the box to the desired location. 

By default, the Preset Buttons are on the bottom of the screen (Figure 30):

Figure 30: Preset Buttons on Bottom

Preset Buttons can also be placed at the top of the screen (Figure 31):

Figure 31: Preset Buttons on Top

Or on the left or right sides of the screen (Figure 32):

Figure 32: Preset Buttons on Sides

Note: Hold [Ctrl], and then click and drag the buttons to arrange them vertically.
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Script Configuration
Before any Script Buttons may be set up, the 
operator must first create scripts to assign to the 
buttons. 

Right-click the Script Button area and click Edit 
Scripts (Figure 33).

Adding Scripts
1.	 Click Add New on the Select Script window (Figure 34).

Figure 34: Adding a Script

2.	 Click Add Line on the Edit Script - Add New screen (Figure 35).

Figure 35: Edit Script - Add New

Figure 33: Edit Scripts
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3.	 Select a scripting command from the Select Scripting Command window (Figure 36).

Figure 36: Select Scripting Command

The remaining steps will differ depending on which script command is selected:

•	 BlankRTD (Venus 7000 only)

•	 BlankSign (Venus 7000 only)

•	 OpenWindow (Venus 7000 only)

•	 Play Sequence

•	 Wait

•	 StartPlaylist

•	 StopPlaylist

BlankRTD (Venus 7000 Only)
The BlankRTD script will blank the 
real-time data in the buffer for the 
display. Up to ten (10) blocks of 
data can be cleared.

1.	 Select BlankRTD from the Select 
Scripting Command window 
(Figure 36).

2.	 Click Next.

3.	 Select the sign on which the 
command will run.

4.	 Click Next.

5.	 The Set RTD Offsets screen will 
appear (Figure 37).

Figure 37: Set RTD Offsets
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6.	 Set the Buffer Destination by selecting either:
•	 Display Buffer: sends the RTD information to display
•	 Capture Buffer: captures the RTD information to a sequence
•	 Both

7.	 Set the Update Mode by selecting either:
•	 Update Immediately: updates data immediately
•	 Update on Refresh: updates data when a sequence is started or refreshed

8.	 Insert the appropriate value in the Offset column for the block(s) of data.

9.	 Insert the appropriate value in the Length column for the block(s) of data.

10.	Click Next.

11.	Verify the command and make sure it is correct, and then click Finish. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box.

BlankSign (Venus 7000 Only)
The BlankSign script will stop a selected sequence that is running on the display.

1.	 Select BlankSign from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 Select the sign on which the command will run, and then click Next.

4.	 Verify the command and make sure it is correct, and then click Finish. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box.

OpenWindow (Venus 7000 Only)
The OpenWindow script opens, moves, or closes one window on the display.

1.	 Select OpenWindow from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 Select the sign on which the command will run, and then click Next. The Open 
Window screen will appear (Figure 38).

Figure 38: Open Window
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4.	 Select the window number that matches the window set up in Venus 7000.

5.	 Click on the drop down menu to select a Command.
•	 Open: Opens the window.
•	 Close: Closes the window.
•	 Move: Moves and opens the window. Enter the row and column position.

Note: If a window moves, the next time it is opened it opens in the previous position.

6.	 Click Next.

7.	 Verify the command and make sure it is correct, and then click Next. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box.

PlaySequence
The PlaySequence command plays a specified sequence on the display.

1.	 Select PlaySequence from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 Select the sign on which the command will run.

4.	 Click Next and the Select Sequence window will appear (Figure 39).

Figure 39: Select Sequence

5.	 Select the Display Mode from the following options:
•	 Continuous: the sequence will play continually.
•	 Times: once selected, insert the number of times in the # of Times box.
•	 Selected Frame: once selected, insert the frame number in the Frame box  

(Venus 7000 only).

6.	 Fill in the information in the Sequence section. For Venus 7000 only, click the Browse 
button to find the appropriate file and fill in all of the blanks in this area.

7.	 Click Next.

8.	 Verify the command and make sure it is correct, and then click Finish. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box. 
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Wait
The Wait script command inserts a pause in the script between commands.

1.	 Select Wait from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 In the Set Wait Time window, 
set the Minutes, Seconds, 
and/or Milliseconds to wait 
(Figure 40).

4.	 Click Next. 

5.	 Verify the command and 
make sure it is correct, and 
then click Finish. The Edit 
Script - Add New screen 
will appear again, this time 
containing the new script 
line in the box.

In order to display pregame 
content, both StartPlaylist and 
StopPlaylist commands must be 
configured. Refer to Section 4: 
Pregame Operation (p.10) for 
more information about setting 
up pregame playlists.

StartPlaylist
The StartPlaylist command is how pregame stat playlists are outputted. 

1.	 Select StartPlaylist from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 Select a single playlist or multiple playlists by holding [Ctrl] while clicking. 

4.	 Click Next.

5.	 Verify the command and make sure it is correct, and then click Finish. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box. 

StopPlaylist
The StopPlaylist command stops sending out pregame stat playlists. 

1.	 Select StopPlaylist from the Select Scripting Command window (Figure 36).

2.	 Click Next.

3.	 Select a single playlist or multiple playlists by holding [Ctrl] while clicking. 

4.	 Click Next.

5.	 Verify the command and make sure it is correct, and then click Finish. The Edit Script - 
Add New screen will appear again, this time containing the new script line in the box. 

After entering the desired command lines to a new script, click Save. A prompt will 
appear to enter a Script Name. Type in a name, and click Save. Once a script is assigned 
to a button as described in Adding Script Buttons (p.27), the script name will appear on 
the button.

Figure 40: Set Wait Time
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Editing Scripts
In the Select Script window, highlight the script to edit, and then click Edit (Figure 41). 
Scripts currently used in script buttons are denoted with (Assigned).

Figure 41: Selecting a Script

In the Edit Script window that appears (Figure 42), operators may select from the 
following options: 

Figure 42: Editing a Script

Inserting a Script Line
1.	 Select the script line that will go immediately after the new script line.

2.	 Click Insert Line.

Note: Add Line places a new line at the end of the list of commands while Insert 
Line places a new line before a selected command. Refer to Adding Scripts 
(p.21) to add a command.

Editing a Line
1.	 Select the script line to edit.

2.	 Click Edit Line.
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Deleting a Line
1.	 Select the script line to delete.

2.	 Click Delete Line.

Save
The Save button saves any changes to the script and closes the Edit Script window.

Save As
The Save As button – available only when editing scripts – is used to rename scripts.

Cancel
The Cancel button cancels any changes or additions, and closes the Edit Script window.

Adding Script Buttons
Operators are able to create Script Buttons for any purpose and at any time. 

1.	 Right-click in the Script Buttons area, and then click Add Script Button (Figure 33). 

2.	 Select the desired script. 

3.	 Click OK. 

Note: If there are no scripts in the Select Script window, refer to Script Configuration 
(p.21).

Editing Script Buttons

Editing Script Button Cell
1.	 Right-click the script button.

2.	 Click Edit Cell.

3.	 Click the desired script.

4.	 Click OK.

Editing Script Files
1.	 Right-click the script button.

2.	 Click Edit Script File (Figure 42) to edit, add, insert, or remove script files. Refer to 
Editing Scripts (p.26).

3.	 Click Save when finished.
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Adding Stat Buttons
There are two primary kinds of Stat Buttons: User Selected or Preset. Preset stat buttons 
are assigned with specific Categories (For the Season, vs. Right-Handed Pitchers, etc.) 
as well as specific stats (AVG, HR, etc.). User Selected buttons, on the other hand, only 
define the stats, allowing the user to select the desired Categories on the fly. 

1.	 Check up to three boxes next to the desired 
stats in the Fixed or Situational Categories 
areas (Figure 43). 

2.	 In the Category Specifics area, click the 
stats or their column headers to highlight 
them (Figure 44). 

3.	 Click the floppy disk icon  below 
the Category Specifics area, and the 
Stat Button Order window will appear 
(Figure 45). 

4.	 Type in an appropriate Button Name. 

5.	 Select one of the following Categories: 

•	 User Selected: allows the operator 
to show the stats in the Stat Order 
list for any selected Fixed or 
Situational Categories. 

•	 Preset: always displays the Fixed or 
Situational Categories shown in the gray 
box with the stats defined in the Stat 
Order list. 

6.	 In the Stat Order list, the stats may be clicked 
and dragged into the desired priority. 

7.	 Click Save to put the new button in the Stat 
Buttons area. 

8.	 To make changes, right-click the button and 
click Edit Button Configuration. This re-opens 
the Stat Button Order window. 

Note: With the Preview box checked, all stats 
assigned to the button will first appear 
in the Category Specifics list. It is then 
necessary to click the play button  
to send the stats to a display. With the 
Preview box unchecked, the stats will be 
sent right when the button is clicked. 

Figure 43: Select Fixed Categories

Figure 44: Select Category Specifics

Figure 45: Stat Button Order
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Maintaining Preset Buttons

Editing Preset Button/Text Color
1.	 Right-click the desired Script or Stat Button. 

2.	 Click Set Button Color or Set Text Color and a color palette will appear. 

3.	 Select or define a new color for the button/text. 

4.	 Click OK. 

Deleting Preset Buttons

Note: The actions below cannot be undone!

Deleting All Script or Stat Buttons
1.	 Right-click within the Script or Stat Button area. 

2.	 Click Remove All Buttons, and Yes to confirm. 

Deleting One Script or Stat Button
1.	 Right-click the desired Script or Stat Button to delete. 

2.	 Click Delete Script Button or Delete Stat Button, respectively, and Yes to confirm. 

Rearranging Preset Buttons
•	 Hold [Ctrl], and then click and drag the preset buttons to a new location. 

•	 The Script and Stat Buttons areas can be expanded or contracted to accommodate 
for more or fewer buttons. 
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7	 Customizing StatVision

Category Titles
When a category title is too long for display or needs abbreviation or editing, use the 
following process to change the category titles. 

1.	 Go to Edit > Category Titles.

2.	 In the Category Titles window (Figure 46), click on a Title to edit. 

3.	 Type in the abbreviated or changed title. Use the legend to insert placeholder text 
(<Year>, <#G>, <Abbr>, etc.) for StatVision to fill with the correct value.

4.	 Press [Enter].

5.	 Repeat Steps 2-4 to modify additional category titles.

6.	 Click Apply to save changes, or click OK to save and close. The Restore Defaults 
button may be used to bring back all of the original titles.

Note: A common title to change is At Stadium. Leaving the title as <Stadium> will use an 
underscore “_” in place of any spaces. Ex: “Fenway_Park” versus “Fenway Park”. 

Figure 46: Category Titles
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Threshold Configurations
StatVision highlights positive stats using threshold values (In-game only). 

To change category thresholds:

1.	 Go to Edit > Thresholds. 

2.	 The Threshold Configuration window will appear (Figure 47). 

Figure 47: Threshold Configuration

3.	 Click on the Batting or Pitching tab. 

4.	 Select a stat under the Stat heading. 

5.	 Under the Minimum Value heading, type in the value that the statistic must meet in 
order to be highlighted (Figure 48). 

Figure 48: Threshold Configuration - Minimum Value

6.	 Change the color options if desired: 

a.	 Click either Indicator Color or Details Color. 

b.	 Choose a color from the palette, or define a custom color. 

c.	 Click OK. 

7.	 Click OK to save the threshold settings. 

Note: Thresholds can only be set for calculated stats. This way they are valid throughout 
the entire season. 

Set Output To Uppercase
Go to Edit > Set Output to Uppercase to display all stats in uppercase letters. 
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8	 Troubleshooting
The following table provides a list of common problems and suggested solutions.  
If a problem occurs that is not listed below or cannot be resolved, contact Daktronics.

Problem Solution

Not receiving visitor information •	 Do a manual download from GameDay Baseball.

Connection attempt failed sending stats/ 
V7000 is not responding to message

•	 Verify that the sign service is running.

•	 Verify that a command port is configured.

Invalid Sign Error / Invalid Sequence

•	 Verify that the configured Sign # in StatVision 
matches the Venus 7000/V-Net sign numbers.

•	 Verify the sign numbers are identical on both the 
primary and backup controllers.

•	 Verify the sequence is configured in StatVision 
with the proper drive, library, and file name. 

•	 Verify the sequence in StatVision exists on both 
the primary and backup controllers.

Template Not Found
•	 Ensure a sequence exists and has been assigned 

for the specific group of stats being sent. Refer to 
Set Up Sequences (p.6). 

Batter not refreshed •	 Click the Refresh  button.

Log File errors

•	 Navigate to “C:\Documents and Settings\All 
Users\Application Data\Daktronics\GameDay 
StatVision” for Windows XP or “C:\ProgramData\
DAKTRONICS\GameDay StatVision” for Windows 
7 and delete the log file for that day. 

Note:	 It may be necessary to view hidden files and 
folders to find these log files. 

Edit > Signs menu option disabled •	 Verify DSTI is running and that it is configured with 
GameDay ports.

Player & Quick Messages do not display 
(V-Net)

•	 Verify the “DSTI DSBA Plr Msg req.DSRC” file is 
pointing to the correct input port. By default this 
is set to “21322”, but it must match the GameDay 
Ingame port configured for the sign (typically 
“23322”).

Red DakStats Indicator •	 Verify DakStats is running and the current day’s 
game is the open competition.

Red DSTI Indicator •	 Verify DSTI is running, the correct Sport and 
Interface are selected, and the competition from 
DakStats is open.

Red Database Indicator •	 Verify the path to the database folder is correct 
(Edit > Data Configuration).

Sending Errors
No Sign is Checked. Check a sign. 

No situations are selected. Check a stat category. 
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A	 Creating Display Sequences

Creating Stat Sequences
This guide illustrates the common sequences used with StatVision to display statistics. 
Sequences must be created in Venus 7000 or Content Studio and assigned in StatVision. 
Most stats can be displayed using just a small set of basic sequences. For more 
information about setting up display sequences, refer to the Daktronics Sport Software 
Baseball Display Cookbook (DD1584319).

RTD Fields in “StatVision Stats”
•	 Bitmap Fields

•	 Player Number , Last Name,  
First name, Full Name

•	 Team City, Name, Abbreviation

•	 Category Description

•	 Stat Fields 1-10

Using the Basic Sequences with StatVision
To set up the sequences in StatVision go to Edit > Sequences. Refer to the screenshot 
below. It is only necessary to set up the sequence configuration for the combinations 
that you intend to use.

Daktronics recommends setting up the following basic sequences to fit the display: 

Default
Specifies the sequence to display when 
the batter changes, such as your default 
batter sequence or a team logo. Leave 
Default blank if you do not want StatVision 
to automatically switch sequences. 

Player Message & Quick 
Message
Specifies a sequence built with “DSTI DSBA 
Plr Msg req”

Elias Message
Specifies a sequence built with “StatVision 
Elias Message”
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Single Category Sequences
By default, 3 stats are shown for the selected category for batters, and 4 stats are shown 
for pitchers. You should always configure the 1 Category, 3 Stats and 1 Category, 4 Stats 
fields. Additional sequences will need to be configured if you will be displaying more than 
the default 3 stats.

1 Category: 3 Stats
•	 1 Text Description

•	 1 Category

•	 3 Stats

1 Category: 4 Stats
•	 1 Text Description

•	 1 Category

•	 4 Stats

Multiple Category Sequences
You may display up to 3 stat categories at a time. For the selected categories, you may 
display 1-10 stats.

Creating sequences for multiple categories is basically the same as the default 
sequences. For the 2nd or 3rd categories, use the RTD fields that begin with “Cat 2” or 
“Cat 3”.

2 Categories: 4 Stats
•	 1 Text Description  

•	 2 Categories

•	 2 Stats

With just the 3 sequences shown above, you can display literally thousands of statistic 
combinations!

Player Name
Number

Cat 1 - Description

Cat 1 -  
Stat Name 1
Cat 1 -  
Stat Field 1

Cat 1 -  
Stat Name 2
Cat 1 -  
Stat Field 2

Cat 1 -  
Stat Name 3
Cat 1 -  
Stat Field 3

Player Name
Cat 1 - Description

Cat 1 -  
Stat Name 1

Cat 1 -  
Stat Name 2

Cat 1 -  
Stat Name 3

Cat 1 -  
Stat Name 4

Cat 1 -  
Stat Field 1

Cat 1 -  
Stat Field 2

Cat 1 -  
Stat Field 3

Cat 1 -  
Stat Field 4

Player Name
Cat 1 - Description Cat 2 - Description

Cat 1 -  
Stat Name 1

Cat 1 -  
Stat Name 2

Cat 2 -  
Stat Name 1

Cat 2 -  
Stat Name 2

Cat 1 -  
Stat Field 1

Cat 1 -  
Stat Field 2

Cat 2 -  
Stat Field 1

Cat 2 -  
Stat Field 2
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Creating Standings and Leaders Sequences
Before creating sequences for pregame leaders and standings:
1.	 Set up a sign to receive the GameDay Pregame data. Refer to Set Up Signs (p.5).
2.	 Create a “Pregame Playlist”. Refer to Creating Playlists (p.11).
3.	 Create “Start Playlist” and “Stop Playlist” script buttons. Refer to Script Configuration 

(p.21).

Design the sequences as follows:

“StatVision Leaders”

Depending on the settings of the Pregame Playlist, StatVision can output up to 4 different 
stat categories per page with up to 10 leaders per category.

“StatVision Standings”

Depending on the settings of the Pregame Playlist, StatVision can output up to 6 regular 
division standings or 13 Wildcard standings.

Note: If using the option of applying color to RTD as described in 
Pregame Options (p.10), be sure to check Color From RTD 
(Venus 7000) or Advanced Field Properties > Color (DMP-7000) 
for each applicable RTD item in the sequence. Color RTD is not 
available for V-Net/DMP-8000 players.

•	 After saving the sequences, set which 
files StatVision should use. Refer to Set Up 
Sequences (p.6). 

•	 Click the Start Playlist script button and make 
the appropriate changes to the sequence 
files if any incorrect values appear. 

Cat 1 League Name

Cat 1 Stat Name

Cat 1 - Leader 1 - Last Name

Cat 1 - Leader 2 - Last Name

Cat 1 - Leader 3 - Last Name

Cat 1 - Leader 4 - Last Name
Cat 1 - Leader 5 - Last Name

Nickname

Nickname

Nickname

Nickname
Nickname

Stat Value

Stat Value

Stat Value

Stat Value
Stat Value

League Name

Division Name

Team 1 Nickname
Team 2 Nickname

Team 3 Nickname

Team 4 Nickname

Team 5 Nickname

Wins
Wins

Wins

Wins

Wins

Losses
Losses

Losses

Losses

Losses

Games Back
Games Back

Games Back

Games Back

Games Back
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