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Section 1: Introduction 

The purpose of this manual is to assist users with outputting and displaying XML files as Real-Time 

Data (RTD) using the Daktronics XML To RTD (DXTR) application. The XML files may be stored 

locally, as generated by another program, or read live over the Internet, such as from an RSS feed.  

 

This manual includes the following main sections: 

 

 Introduction covers basic information about the program and this manual.  

 Installation & Registration, Setup & Operation, and Creating Display Sequences explain 

how to control and configure the application. 

 Contact Information offers details about who to contact for help.  

 

Daktronics identifies manuals by an ED or DD number located on the cover page. Any other 

documents referenced in this manual will be identified by the ED/DD number. For example, this 

manual would be referred to as DD1699931.  

1.1 Software Requirements 

 Windows® XP or higher 

 CPU: 1 GHz or faster 

 Memory: 512 MB 

 20 MB free hard disk space 

 Internet access required when 
reading XML files online 

1.2 Software Conventions 

This manual contains the following software conventions and terminology: 

 

Bold Indicates an item that requires direct action, such as clicking, pressing, 
selecting or formatting. 

Italics Indicates onscreen text or labels that are not clickable. 

Bold Italics Used to reference items within the manual, such as figures or sections, as 
well as other documents and important notes.  

[X] Represents a keyboard key that needs to be pressed. 

“Quotes” Text or commands that may be typed. Quotes also indicate folder names. 

Click Press and release the left mouse button. 

Double-click Press and release the left mouse button twice. 

Right-click Press and release the right mouse button. 

Select Highlight or mark, such as by placing a check mark  in a nearby box; 
clicking will not necessarily perform an action. 

> Followed by (ex. File > Open). 
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Section 2: Installation & Registration 

2.1 Installation 

The DXTR program can be downloaded from the Internet:  

 

1. Open an Internet browser. 

2. Type “http://dakfiles.daktronics.com/downloads/Sports_Products/DXTR/” into 

the address bar. 

3. Click the “DXTR_Install.exe” file. 

4. In the window that appears, click Run. If an additional window opens, click Run 

once more.  

5. Follow the onscreen instructions. 

6. Click Finish when done.  

2.2 Registration 

When the DXTR program is first opened, users are required to attain a new software license 

in order for the program to work.  

 

To renew the subscription: 

 

1. Highlight and Copy the Lock Code. 

2. Email the Lock Code to support@dakstats.com with the subject line “DXTR Lock 

Code” and a license file will be emailed back. 

3. When the license file is received, save it to a location that is easy to remember, such 

as “My Documents” or the “Desktop”. 

4. Click Load License, and then locate and open the license file. 

5. Click Continue to begin using the DXTR program. 

 

http://dakfiles.daktronics.com/downloads/Sports_Products/DXTR/
mailto:support@dakstats.com
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Section 3: Setup & Operation 

After opening the DXTR program, 

users will see the main application 

screen (Figure 1). Here users may view 

and configure the RTD outputs from 

the preconfigured inputs, as well as 

adjust the paging settings for the input 

maps. Users may also view messages 

of all application actions that have 

taken place since it was first opened.  

3.1 Inputs 

Creating Inputs 
To create inputs, the user must 

contact Daktronics with a 

detailed description of what 

XML file or URL will be used, 

as well as what specific data 

should be taken from the file. 

 

IMPORTANT! Users must have permission from the data provider to show the desired 

information on their displays. Daktronics may not be held responsible for unauthorized 

transmission of copyrighted content. 

 

Daktronics will create an appropriate input map file and send it to the user. All input map 

files must be saved in the following directory:  

“C:\Documents and Settings\All Users\Application Data\Daktronics\DXTR\Maps” 

 for Windows XP or “C:\ProgramData\Daktronics\DXTR\Maps” for Windows 7. 

 

When the DXTR program is opened, all configured inputs (max of 10) should appear under 

the Inputs list at the top of the screen (Figure 1).  

Configuring Inputs 
To configure an input: 

 Click on an input from the list and then go to 

Configure > Edit Input.  

 Right-click on an input from the list and 

select Edit Input.  

 

In the Configure Input window (Figure 2), the 

following settings may be edited:  

 

 The Refresh Time sets the number of seconds 

to wait between reading the information 

coming from the XML file. The default and 

minimum number is “6”. 

 
Figure 1: DXTR Main Application Screen 

 
Figure 2: Configure Input Window 
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 The Source is the path from which DXTR is pulling the information. If the source is 

incorrectly formatted, Invalid will appear above it; otherwise it will display Valid. 

Click Default to return to the original source settings. 

 

Click OK when finished. 

Monitoring Inputs  
Right-click the input in the list and select Monitor. 

This will open the Input Monitor window (Figure 

3) to view the XML file that the input is currently 

reading from.  

 

Use this window to make sure the input is reading 

the correct XML file. 

3.2 Outputs 

Creating Outputs 
To create an output: 

 Go to Configure > Add Output. 

 Right-click in the Outputs list and select Add 

Output. 

 

In the Configure Output window (Figure 4), enter the 

following settings: 

 Name: type in a descriptive name for the 

output. 

 Map: select an input map to read from. 

 Flush Buffer Duration: type in the number of 

seconds to wait before resending the output 

data; leave at “0” to send data only at the 

specified hold time (see Section 3.3). 

 Port Configuration: click Configure to set up 

the output port (Figure 5): 

o Type: Typically this will be UDP/IP. 

o Port: With UDP/IP selected, type 

in an available port number. 

o Click OK when finished 

configuring the port. 

 

 Click OK when finished configuring 

the output. 

 

After creating an output, it will appear in the 

Outputs list in the middle of the main 

application screen.  

 

Note: There is a maximum of 10 outputs. 

 
Figure 3: Input Monitor Window 

 
Figure 4: Configure Output Window 

 
Figure 5: Port Configuration Window 
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Editing Outputs 
To edit an output: 

 Click on an output from the list and then go to Configure > Edit Output.  

 Right-click on an output from the list and select Edit Output. 

 

Editing an output will open the Configure Output window as shown in . Adjust any of the 

output settings as needed and click OK when finished to save the changes. 

Deleting Outputs 
To delete an output: 

 Click on an output from the list and then go to Configure > Delete Output.  

 Right-click on an output from the list and select Delete Output. 

Monitoring Outputs 
Right-click the output in the list and select Monitor. 

This will open the Output Monitor window (Figure 6) 

to view the information being outputted as RTD.  

 

Use this window to make sure the output is correctly 

sending out data. 

 

Note: In order to see the output data, users must first 

start the output (see Section 3.5) 

3.3 Editing Input Maps 

Maps link between the information that comes 

through an input and the fields that will be displayed. 

Maps are created by Daktronics (see Section 3.1), but 

there are a few settings that users can configure. 

 

1. Go to Configure > Edit Maps. 

2. In the Configure Map window (Figure 7), select 

the map to edit from the Maps drop-down box. 

3. Under the Paging options, use the drop-down 

box to select the type of data to page. The 

same XML input may have several paging lists 

with different information to display.  

4. Use the Hold Time to determine how long in 

seconds to display each group of items before 

moving to the next data set. 

5. Enable Wrap Items At End to place items at 

the end of the list that would normally be at 

the beginning to fill in all the spaces. If this 

option is disabled, there may be blank spaces 

at the end of the list. 

 

Note: Individual items may also be word wrapped across several lines. This must be 

specified to Daktronics when creating the input maps. 

 
Figure 6: Output Monitor Window 

 
Figure 7: Configure Map Window 
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3.4 Generating ITFs 

An Input Template File (ITF) is needed for Daktronics display controllers to know when one 

piece of data ends and another piece of data begins within a continuous output stream. ITFs 

are used when creating the RTD display sequences (see Section 4). 

 

To generate an ITF: 

 Click on an input from the list and then go to File > Generate ITF.  

 Right-click on an input from the list and select Generate ITF. 

 

1. In the Browse For Folder window, navigate to the directory where the ITF should be 

saved, and then click OK. ITFs will typically be saved in the “C:\V7000” or 

“D:\V7000” folder.  

 

Note: If an input has more than one map, users will have to select which map to use 

before saving the ITF. 

 

2. When the file is successfully generated, click OK. 

3.5 Sending Data 

Before starting the output(s), make sure all 

of the following steps have been performed:  

 

 Configure the input(s) (Section 3.1). 

 Create the output(s) (Section 3.2). 

 Set the input map paging options 

(Section 3.3). 

 Generate an ITF (Section 3.4). 

 

Once the above settings are correct, go to 

File > Start to begin outputting the data 

across the configured port(s).  

 

Note: If all inputs and outputs are 

properly configured, the output(s) will 

autostart the next time the program is 

opened. 

 

The indicators to the left of each input and output turn bright green when sending or 

receiving and dark green when connected but idle (Figure 8). If an input indicator is orange, 

the XML source cannot be read, and the error will also be displayed in the Messages area. 

3.6 Help Menu 

 Go to Help > About to view program, licensing, and system information. 

 Go to Help > View Manual to open a PDF version of the software manual. 

 Go to Help > View Today’s Log File to open a text file containing a list of program 
events for the current day. Use the log file to troubleshoot any problems with the 
input or output connections. 

 
Figure 8: Output Started 
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Section 4: Creating Display Sequences 

With the DXTR program running and minimized and the correct ITF generated, users may create the 

display sequence that will show the XML data as RTD.  

 

Note: This section focuses on the Venus® 7000 display control software. Refer to the documentation 

provided with the particular Daktronics display control software in use for more information on 

setting up RTD inputs and display sequences.  

4.1 RTD Input Setup 

1. Open the “Venus 7000 Shell”. 

2. Click Configure, and then click the RTD 

Inputs tab. 

3. Click an available RTD input, and then 

click Edit Input. 

4. Set up the input as follows (Figure 9):  

 Name: A descriptive name that makes 

sense to the user for the type of data 

being displayed 

 Source Type: UDP/IP SOCKET  

 Source: Enter the UDP output port 

number set up in DXTR (refer to 

Section 3.2) 

 Protocol: Enhanced 

 Default Input Template: Select the ITF created in DXTR (refer to Section 3.4). 

 

5. Click OK on the Edit RTD Input and System Configuration windows, and then restart the 

sign service when prompted. 

6. To make sure the settings have been configured properly, click Diagnostics, and then 

click the RTD tab. 

7. Select the DXTR Input that was just created, and data from the XML file should appear 

(Figure 10).  

 

Note: It may be necessary to click Refresh to make the data appear. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 9: Edit RTD Input Window 

 

 
Figure 10: RTD Diagnostics 
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4.2 RTD Sequence Setup 

1. From the “Venus 7000 Shell”, click Edit. 

2. Open or create a new sequence for the sign that will display the XML data. 

3. Go to Frame > Insert > Data Frame. 

4. In the Frame Properties window, click the Data Field Parameters tab. 

5. Set up the data field as follows:  

 Field Type: RTD  

 Input: Select the input created in Section 4.1  

6. Under the Field Name, select a field from the ITF that 

corresponds to a piece of data from the XML file.  

7. Change the Field number to “2” and repeat steps 5-6 

until all desired pieces of data are in the display 

sequence. 

8. After assigning the item numbers to each data field, 

click OK. Be sure to delete the first graphic frame 

(Frame > Delete). 

9. Click the preview button (or press [F5]) to view the 

sequence and ensure the correct data is displaying 

(Figure 12). 

10. Modify the appearance of the sequence as desired 

and Save. 

 

 

 

 

 

 

 

 

 

 

 
Figure 11: Frame Properties Window 

 
Figure 12: Sample Display 
Sequence 
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Section 5: Contact Information 

If there are any questions about the DXTR program, please contact DakStats Customer Service: 
 

 

Mail: Daktronics, Inc., Customer Service 
201 Daktronics Drive 
P.O. Box 5128 
Brookings, SD   57006 
 

Phone: DakStats Help Desk: 1-888-325-7828  
 

DakStats Fax: 1-605-697-4700 Attn: DakStats 
 

Email: support@dakstats.com  
 

mailto:support@dakstats.com
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Appendix A: Twitter Feeds 

Input Creation & Authorization 

Twitter requires authentication before DXTR can read and parse tweets for display.  

 

1. Contact Daktronics (support@dakstats.com) to request the DXTR Twitter Map File.  

 

2. Once the “TwitterOauth.xml” file is received, copy it to: 

“C:\Documents and Settings\All Users\Application Data\Daktronics\DXTR\Maps” for 

Windows XP or “C:\ProgramData\Daktronics\DXTR\Maps” for Windows 7. 

 

3. Open DXTR after copying the map file to the correct directory. 

 

4. Right-click “TwitterOAuth” in the Inputs section and select Edit Input.  

 

 
 

5. In the Configure Input window, click Authenticate.  

 

 
 

6. At this point, the software will bring 

up an internet browser window 

requiring the user to login to their 

twitter account. 

 

7. Enter valid Twitter account login 

credentials and click Authorize app. 

 

Note: This is not necessarily the 

account that tweets will be pulled 

from; Twitter just requires a valid 

login for the DXTR software to 

access their data feeds. 

 

 

 

 

 

 

mailto:support@dakstats.com
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8. Once logged in, Twitter will provide a unique PIN. Copy and paste the PIN into the Authorize 

Twitter window in DXTR, and then click OK. 

 

 

 

 

 

 

 

 

 

 

9. Back on the Configure Input window, notice that the word “Authenticated” now appears after 

successfully granting access to DXTR.  

 

a. Select the Search Type: 

 Show Specific User Tweets: 

(Recommended) 

Select to show tweets for the 

specific Twitter account entered 

in the Search Value field. 

 

Use this option to show tweets 

that are retweeted to a specific 

“display only” Twitter account to 

allow for message moderation. 

 

 Search All Tweets: Select to 

return all tweets that include the 

term(s) in the Search Value field. 

 

Use this option carefully!  

There is no moderation with this 

option, so any tweet that includes 

the Search Value will be returned.  

 

Entering multiple search terms will make the search more exclusive NOT inclusive. 

For example, “DakStats, Daktronics” will only show tweets that include both of these 

terms and not every tweet that has either term. 

 

b. Ensure the Refresh Time is no less than 30 seconds. Twitter will turn off an RSS feed if 

something hits it more than 150 times per hour, so a refresh rate over 30 seconds 

shouldn't max that out. 

 

10. Click OK when finished. 
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Output Creation & ITF Generation 

1. Go to Configure > Add Output. In the Configure Output 

window, set up the output as follows: 

 Name: "Twitter" or descriptive name of feed  

 Map: "TwitterOAuth.TwitterOAuth"  

 Flush Buffer Duration: typically "0"  

 Port Configuration: Click Configure, select UDP/IP as 

the Type, set the Port number (typically "28000" range), 

and click OK.  

 Click OK again when finished.  

 
2. Close and reopen DXTR. There should be green indicators 

next to both the TwitterOAuth input and Twitter output to 
show they have been created and authenticated correctly.  
If not, double-check the settings and right-click the 
input/output and select Monitor to verify data is being 
received/transmitted.  
 

3. Right-click the input and select Generate ITF. Navigate to the appropriate directory 
(typically "D:\V7000") and then click OK.  
 

Note: If using Content Studio for DMP-7000 or DMP-8000, there are a couple additional files 
that will be needed. Please contact Daktronics to have these files created and installed.  

 

4. Create the Venus 7000 RTD input to match the UDP output, and then create the display 
sequences with RTD fields like any other data source. Refer to Section 4. 
 
Note: Again, if using Content Studio, additional setup is required to create RTD inputs. 
Please contact Daktronics.  

 
 

RTD Field Settings 
 
ITF: “TwitterOAuth” 

 
RTD Field Name Item# Length Field Type 

Twitter_1_Username 1 30 RTD 

Twitter_1_ScreenName 31 30 RTD 

Twitter_1_UserAvatar 61 200 BMP / Media RTD 

Twitter_1_TweetText_1 261 100 RTD 

Twitter_1_TweetText_2 361 100 RTD 

Twitter_1_TweetDate 461 20 RTD 

Twitter_1_TweetPic 481 200 BMP / Media RTD 

 

The default ITF is configured to show up to 200 characters of text per tweet, wrapping to a new line at 

100 characters. There are also extra fields for username, screen name, user avatar, tweet date, and a 

tweet pic if applicable. DXTR will display all tweets specified in the input Search Value one tweet at a 

time for 10 seconds each. To change any of these default settings, please contact Daktronics. 
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