How do I remove duplicate players in my DakStats roster

Potential Symptoms

  • I have duplicate players in my DakStats roster.
  • One of the duplicate players has no season stats.

Environment

  • Product Family: Sport Software and Interfaces
  • Product: DakStats
  • Components: DakStats Web-Sync
  • Control System:

Potential Cause

  • Duplicate players may occur for various reasons.

Resolution

  1. Go to Configure > Rosters, and select your team.
  2. Click on the first instance of the player, hold the [Ctrl] key on your keyboard, and then click on the second instance of the player.
  3. Click the Merge button that appears in the bottom right portion of the screen.

Work Around

The above steps will solve the issue in most cases; occasionally you will be unable to merge the players without some additional action. The following steps describe the entire process. 

NOTE: If both instances of the player have statistics in Play-by-play games, it will not let you merge them. You will receive a message that says “Both players have stats in Play-by-play games. Please manually edit the play-by-play games so that only one of the players has stats.”

  1. Attempt to delete one of the players. It will show you a list of Play-by-play
        games available.
  2. Once you have made a note of the games, open each game individually.
  3.  A message may appear stating "Play-by-play not found, opening in box
        mode." Click OK.  
    NOTE: If you don't get this prompt go to View->Box Score by Game. Double click on any player, you'll get a message telling you the Play by play data will be lost. Click OK. Then close the game.
        By doing this you'll be allowed to merge the players.
  4. Go to Configure > Rosters and attempt to merge the players again.
  5. Sync, you'll get duplicate players again just delete the new ones.
  6. Sync a final time to save the roster, shouldn't have any more duplicates.
  7. If the duplicate player will not delete check to ensure the player is not set to disabled. If so Enable the player and Save. Then sync.
  8. Then delete the player and sync to delete from the Web-Sync site.

NOTE: If both instances of the player have statistics in the same game, it will not let you merge them. You will receive the message, “Both players have stats in the following game. Please manually edit the game so that only one of the players has stats.” Open the game in a box score mode (See the note in step b) and find the duplicate players. Move all of the statistics from one player to another, so that the duplicate has all 0's for stats. For example if the main player has two at bats and the duplicate has one, change the duplicate players stat to zero and set the main player to three. Once this is done you should be able to merge the players.

KB ID: DD2610884


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