Nucleus error log shows Underlying connection closed: Could not establish trust relationship; Corrupt Nucleus certificate

Potential Symptoms

  • Receive the following error in the Nucleus Error.log:
    • The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel, but the error is not showing in the Fusion Event log.

Environment

  • Product Family: Software
  • Products:
  • Components: Nucleus Server
  • Control System: Venus 1500 v4

Cause

  • The Nucleus Certificate has become corrupted.
  • This error does not appear in the Fusion Event logs. If you see this error in the Fusion Event logs, please see the following article:

Resolution

Step 1: Remove the existing certificate, this can be performed by using Microsoft Management Console (MMC).
 
Microsoft Management Console (MMC)
  1. Go to Windows Start Menu.
    • Windows XP - Click Run, type MMC and hit [Enter]
    • Windows Vista or 7 - In the Search Programs and Files, type MMC, select MMC from filtered Start Menu
    • Windows 8 - Hover to bottom right of desktop, click Magnifying Glass, type MMC and hit [Enter]
  2. From the MMC Console, click File -> Add/Remove Snap-in.
  3. Under Available snap-ins menu, select Certificates and click Add > to push to Selected snap-ins menu.
  4. From the Pop-up window, select Computer Account and click Next.
  5. Leave on or select Local Computer and click Finish.
  6. Click Ok.
  7. In the Name panel, double-click Certificates (Local Computer).
  8. In the Logical Store Name panel, double-click Trusted Root Certification Authorities.
  9. In the Object Type panel, double-click Certificates.
  10. Under the Issued To column, browse and select the Daktronics Nucleus.
    • Below is a screen shot view of what you should see
    • If the Daktronics Nucleus is not listed, proceed to Step 2
    • MMC Nucleus.png
  11. Once Daktronics Nucleus is Selected, click the Red X, hit [Delete] or go to Actions -> Delete.
  12. Click Yes to the prompt.
  13. Close out of the MMC Console, click No to save the Console.
Step 2: Re-install the Daktronics Nucleus Certificate by running a software repair Venus 1500 v4 or installing Venus 1500 v4.

or

  • Follow How do I update or download Venus 1500 v4 software?, DD1993540
    • Do not uninstall Venus 1500 v4 if currently installed; instead, perform a software repair.

KB ID: DD2605323


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