# Table of Contents

## Section 1: Introduction
- System Requirements ........................................... 1
- Software Conventions ........................................... 1

## Section 2: Installation & Registration
- Installation ................................................................ 3
  - Downloading from the Internet ................................ 3
- Opening & Exiting the Application ............................... 3
- Registration ........................................................... 3

## Section 3: Operation
- Communications ..................................................... 5
  - Network Setup ..................................................... 5
  - Serial Port Setup ................................................ 6
- Startup .................................................................. 7
  - Choose Configurations ......................................... 7
  - New Event Order ................................................ 7
- OmniSport 2000 Pro Swimming Software Overview ........ 8
  - Lane Indicators, Buttons, & Icons ........................... 8
  - Event Data ........................................................ 9
  - Main Application Screen Tabs ................................. 10
    - Current Race .................................................. 10
    - Stored Races .................................................. 11
    - Scoreboards ................................................... 11
    - Test ................................................................ 12
- Pro Configuration .................................................. 12
  - Pool ................................................................ 13
  - Timer ................................................................ 13
  - Console Printer .................................................. 14
  - Pro Printer ........................................................ 15
  - SCBD ............................................................... 16
  - Results ................................................................ 16
  - Event Order ....................................................... 17
  - Comm Ports ....................................................... 18
- Lane Colors ............................................................ 18
- Typical Operation .................................................. 19
  - Before the Meet ................................................... 19
    - Verify the Configurations ..................................... 19
    - Test the System ................................................ 19
    - Set Up Event Order ............................................ 19
  - Before a Race ...................................................... 19
    - Verify Console Settings ....................................... 19
    - Verify the Lengths ............................................. 20
    - Always Ready Start .......................................... 20
  - During a Race ..................................................... 21
    - Lane Status ..................................................... 21
  - After a Race ....................................................... 21

## Appendix A: Software Revision History ........................................... 23

Table of Contents
Section 1: Introduction

The OmniSport 2000 Pro Swimming software interfaces with the OmniSport 2000 timer and allows timing officials to control the competition through an easy-to-use, reliable and convenient Windows®-based user interface installed on a Windows compatible computer system.

This manual describes how to install, configure, and operate the Daktronics OmniSport 2000 Pro Swimming software system, Version 3.0.0 or higher.

Daktronics identifies manuals by an ED or DD number located on the cover page of each manual. Any manuals referenced in this document will be identified by its ED/DD number. For example, this manual would be referred to as DD3109473.

1.1 System Requirements

The OmniSport 2000 Pro Swimming software was designed to operate on a Windows compatible personal computer. In most circumstances, the computer used by the software will be purchased through Daktronics. This ensures the software requirements will be met. If a computer is not purchased through Daktronics, the following list describes the requirements for the OmniSport 2000 Pro software.

- Windows XP operating system or better (Windows 7/8 is supported only in Pro Swimming version 1.2.2 or higher - both 32 & 64 bit operating systems are supported)
- 2.26 GHz or faster CPU
- 2 GB RAM
- Internet Explorer® 5.0 or higher
- One Ethernet jack OR one serial port for connection to the OmniSport 2000 console (one USB port and USB-to-serial adapter may be used in place of a serial port)

1.2 Software Conventions

This manual contains the following software conventions and terminology. Note that these instructions are based on the standard, right-handed mouse configuration.

| **Bold** | Indicates an item that requires direct action, such as clicking, pressing, selecting or formatting. |
| **Italics** | Indicates onscreen text or labels that are not clickable. |
| **Bold Italics** | Used to reference items within the manual, such as figures or sections, as well as other documents and important notes. |
| [X] | Represents a keyboard key that needs to be pressed. |
| “Quotes” | Text or commands that may be typed; also indicate file or folder names |
| **Click** | Press and release the left mouse button. |
| **Double-click** | Press and release the left mouse button twice. |
| **Right-click** | Press and release the right mouse button. |
| **Select** | Highlight or mark, such as by placing a check mark ✓ in a nearby box; clicking will not necessarily perform an action. |
| > | Followed by, as in menu navigation (ex. File > Open). |
Section 2: Installation & Registration

2.1 Installation

Downloading from the Internet
To install the Pro Swimming software from the Internet:
1. Open an Internet browser to:
2. Click the “OmniPROSwimmingInstall.exe” file, and then click Run (twice if necessary) to begin the installation procedure.
3. Follow the onscreen instructions to complete the installation.

2.2 Opening & Exiting the Application
To open the application:
- Double-click the “Swimming” icon on the desktop (Figure 1).
- Click the Start menu and navigate to All Programs > Daktronics > OmniSport Pro > Swimming.

To exit the application:
- Click the exit button in the upper-right corner of the window.
- Left- or right-click the icon in the upper-left corner of the window and click Close.
- Go to File > Exit.

2.3 Registration
After installing the Pro Swimming software, users are given a 30 day trial period (Demo Mode). Each time the program is opened, the number of days remaining for the free trial is shown. To use the software without registering, click Continue. When the 30 day trial period is over, users must register the software as described below:

1. On the Register OmniSport 2000 Pro window (Figure 2), make a note of the Serial #. Email the Serial # to sportsoftware@daktronics.com with the subject line “Pro Swimming License”. Be sure to also include the name of your organization, facility name, and/or contract number for the fastest response. Upon proof of purchase, Daktronics will email a software license file.
2. Save the license file to the Pro Swimming computer.
3. Back on the Register OmniSport 2000 Pro window, click Load License, browse to the location where the license file was saved, and then Open it.
4. After successfully registering, click Continue to begin using the software.

Note: Installing the software on a separate computer requires a new license file.
Section 3: Operation

3.1 Communications

The Pro Swimming Software can communicate with an OmniSport 2000 console in one of two ways: via network (Ethernet) or serial (COM) port.

Network Setup
1. Ensure there is a Cat5 Ethernet cable connected between a network router and the ETHERNET jack on the OmniSport 2000 timer as well as another cable running from the router to the Pro Swimming computer’s network jack.
2. Power on the console, set the name, date, and time, and then select 1-SWIMMING.
3. Start the Pro Swimming software (see Section 2.2).
4. Go to Options > Configure and click on the Comm Ports tab (Figure 3).

5. Click Configure in the Interface Comm Port area.
6. In the window that appears (Figure 4), select UDP/IP as the Type and then click Apply followed by Finish.

7. Back in the Interface Comm Port area, click Monitor (Figure 26).
   - If the computer is receiving data in the top half of the monitor window, the connection was made properly and the correct communication settings are configured. Data on the bottom half is being sent by the Pro Swimming software.
   - If the computer is not receiving data, ensure a proper connection between the OmniSport 2000 console, the network router, and the Pro Swimming computer.
Serial Port Setup

1. Ensure a straight-through 9-pin male to 9-pin female serial cable is connected between the computer’s serial port and the J4 EXPANSION PORT on the OmniSport 2000 timer (a USB-to-serial adapter may also be required).
2. Power on the console, set the name, date, and time, and then select I-SWIMMING.
3. Start the Pro Swimming software (see Section 2.2).
4. Go to Options > Configure and click on the Comm Ports tab (Figure 3).
5. Click Configure in the Interface Comm Port area.
6. In the window that appears (Figure 5), select COM Port as the Type.

Figure 5: General Setup

7. Click on the Com Settings tab (Figure 6). Select an available COM Port, set the Baud to 38400, and then click Apply followed by Finish.

Figure 6: Com Settings

8. Back in the Interface Comm Port area, click Monitor (Figure 26).
   - If the computer is receiving data in the top half of the monitor window, the connection was made properly and the correct communication settings are configured. Data on the bottom half is being sent by the Pro Swimming software.
   - If the computer is not receiving data, go back to step 7 and select a different port. Do this until data is received through the selected port.
Note: Some computers purchased with this software will have a Rocket® port installed with the system. The port labeled Port 0 will be normally set as COM port 5 in the computer system. The next port would then be COM 6, then COM 7, and finally COM 8 for a four-port Rocket port. The OmniSport 2000 Pro software recognizes these ports no matter what port number has been assigned to them.

3.2 Startup

Once the hardware and software have been installed and the software is running, the OmniSport 2000 Pro system should synchronize with the timer. If the message Cannot Detect Console appears, then the cable is not connected, or the wrong communication settings are configured. Refer to Section 3.1 to ensure proper connection/configuration.

Note: If the cables are connected properly, the Comm Status indicator on the main application screen (Figure 10) will be green. This indicator flashes green when receiving data and turns orange when not connected.

Choose Configurations

If there are multiple OmniSport consoles on the network, a message similar to Figure 7 will appear. Select the correct OmniSport Console from the list and click OK.

Note: The chosen console name is shown on the main application screen next to the Comm Status indicator.

Once the hardware has been connected and the software is running, a message may appear requesting which configuration settings are preferred (Figure 8). Select Console to retain the settings from the OmniSport 2000 (recommended), or Pro to use the default settings of the software.

New Event Order

When the Pro software is started, the OmniSport 2000 timer sends the event order data. If a file has not yet been created for this event order, the software will ask whether or not a new file should be created (Figure 9). To create the file, click Yes, type in a descriptive File Name, and click Save.

This is an excellent way to store old event orders and use them again. The OmniSport 2000 timer is only able to store 500 different events. The Pro Swimming software can store several of these event lists, each with 500 different events. Those lists can be edited and reused. Refer to Section 3.4 for more information on editing the event order.
3.3 OmniSport 2000 Pro Swimming Software Overview

Once the OmniSport 2000 Pro system is configured and synchronized, event management is quick and simple. The Horn Start 200 start system starts the timer. The touchpads, backup buttons, and lane modules obtain split and final times. In addition, this system sends data to output devices, including matrix displays, numeric scoreboards, and paper printouts.

This section describes the operational buttons, lane icons and indicators, and operations of the OmniSport 2000 Pro system. The main application screen is illustrated in Figure 10.

![Figure 10: Main Application Screen](image)

Lane Indicators, Buttons, & Icons

The lane indicators, buttons, and icons relay event information to the user. This information should be used to determine timing discrepancies and event results. It is also editable from the main application screen of the software system.

Figure 11 shows the lane information. Each area displays information editable on each lane.

- **Lane On/Off** area is a toggle that turns that lane on or off. If the lane is OFF, no data will be received for this lane. Turn the lane off if no swimmer is using it during the current event.

  **Note:** [F1] toggles Lane 1 On/Off, [F2] toggles Lane 2 On/Off, and so on.

- **Current Lengths** can be changed by clicking [↑↓] buttons on the right side of this area. Use this to subtract an accidental touch or to add a missed touch. The current length will not go beyond the maximum lengths set for the current event.

![Figure 11: Lane Information](image)
• Near/Far Lane Indicator displays the current arming state of the lane. The table below describes each icon and what it represents.

• Arming Buttons are used to change the lane arming status during an event. There may be a time when a swimmer's touch is not registered by the touchpad. When this happens, use these buttons to change the arming of the lane.

<table>
<thead>
<tr>
<th>ICON</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Near Far</td>
<td>Split Armed. When this is showing, this lane is armed to take a split time.</td>
</tr>
<tr>
<td>Near Far</td>
<td>Finish Armed. When this is showing, this lane is armed for a finish time.</td>
</tr>
<tr>
<td>Near Far</td>
<td>Finished. This indicates the lane is finished timing.</td>
</tr>
<tr>
<td>2</td>
<td>Arming Delay. This is the amount of time left until the touchpad is active. A number from 1-99 will display decrementing by one every second.</td>
</tr>
<tr>
<td>?</td>
<td>Lane Problem. This indicates a problem has occurred within the lane.</td>
</tr>
<tr>
<td>!</td>
<td>Overly active input. This typically results from a bad connection or pushbutton.</td>
</tr>
<tr>
<td></td>
<td>Replace the batteries in the RTOP for that lane.</td>
</tr>
</tbody>
</table>

Event Data
The top area of the main application screen (Figure 12) displays current event details and options. The elapsed time is displayed to the right of the Daktronics logo. The Event, Heat, Length, and Round are set by the event order file, but may be selected by clicking the [↑↓] buttons to the right of the data fields. The operator must manually increment the event number, heat number, and round at the end of an event or heat. To change the event order file, refer to Section 3.4.

![Figure 12: Event Data Area](image)

Note: Though editing may be done, the data will not be saved in the event order file.

• Clicking STORE PRINT will store the current event data into an event file and print the results according to the configurations.

• Clicking RESET will reset the time and begin a new event. RESET also stores the current event data into an event file and prints the data according to the current print configurations if STORE PRINT was not clicked.
The upper left area of the main application screen contains five buttons (Figure 13) used before and during events.

The buttons are described below from left to right:

1) **Edit Start Time** allows the user to change the start time of any event. This is not enabled during events (mainly used when a start input is missed).

2) **Disqualify** toggles a swimmer’s disqualification flag. Click this button and select the lanes to be disqualified.

3) **Split Arm All** arms all touchpads to take split times.

4) **Finish Arm All** arms all touchpads to take finish times.

5) **Race Log File** opens the race log file for the current race.

**Main Application Screen Tabs**
The main application screen (Figure 10) contains four tabs. Click on the tab to switch between the different functions.

**Current Race**
The **Current Race** tab (Figure 14) allows the user to view, print, and edit the current event.

- **Name**, **Affiliation** and **Time** are all editable fields. To edit these fields, click on a desired field and click **Edit**, or simply double-click in the selected field.
- To disqualify a lane, select the lane row and click **DQ**.
- Click **Split Arm All** or **Finish Arm All** to arm the touchpads for split times or finish times, respectively.
- Press **Start** to initiate the timing system and press **Store Print** to send the current event data to the printers and save the data into a file. Clicking **Start** shows the start source on printout results as a keyboard, designating an unofficial start of the race.
Stored Races

The Stored Races tab (Figure 15) allows the user to view, print, and edit stored events.

- Select the appropriate Database File, Title, Race, Event, Heat, Length, and Date/Time.
- The Name, Affiliation, and Time are all editable. To edit these fields, click on a desired field and click Edit or double-click in the selected field.
- Press Print to send the stored race data to the printer, and click Save to store the edited data to a file.

Another editing option for the user is to right-click on a field (Figure 16) and select an option from the following menu:

- **Edit** allows the user to change the field.
- **DQ** initiates the disqualification flag for that lane.
- **Use Backup** sets the backup time as the lane time.
- **Lane Log** opens the lane log file.

Scoreboards

The Scoreboards tab (Figure 17) controls what is shown on the display.

- Pressing Set Display Off turns the scoreboard off. Click again to turn it back on.
- Pressing Show Time of Day shows the time-of-day on the scoreboard.
- Use the slider to adjust the scoreboard Dimming.
- The Display to Matrix area contains options for displaying data on a matrix display. Select the desired Event, Heat, and Round information. Then select a type of information (Start List, Event Results, Heat Results, Women’s Scores, Men’s Scores, or Combined Scores). Click Request to send the selected information to the display.
- The Team Scores text boxes show what the current team scores are.
Test

The Test tab (Figure 18) is used to test the battery, display, lane modules, and touchpads.

- The Battery field displays the power source and the power level of that supply.
- The Lane Modules field displays which touchpad or backup button is being activated. An X indicates the lane being tested if the equipment is working properly. It is possible to enable and disable certain devices and lanes by clicking the appropriately labeled buttons. This test procedure requires at least two people; one to monitor the system and another to activate the input devices.

If there is only one person available, click Lane Module Test Mode, then turn the computer monitor so it can be seen from the touchpads and lane modules. Go to the input devices and active them. The monitor will display the activated device so that it can be seen from the poolside.

- The Scoreboard section contains three buttons for testing the scoreboard:
  - Cycle On/Off: Click to send an all on signal to the scoreboard approximately every 3 seconds until deselected.
  - Show Address: Click to display the driver addresses. The number or letter will show which output on the driver that digit is plugged into.
  - Show Digit: Click to confirm the digits are operational and properly plugged at the time of installation and if the system needs debugging.

3.4 Pro Configuration

Configuring the Pro Swimming software is important for managing swimming events. To access the Pro configuration, go to Options > Configure on the main application screen.

Much of this information pertains to both the OmniSport 2000 Pro software and the OmniSport 2000 console. For information about the equivalent console settings listed in this section, refer to Section 5 of the OmniSport 2000 manual (ED-13312).
Pool
The Pool tab (Figure 19) configures the OmniSport 2000 Pro software to the particular pool being used.

- Select the Number of Lanes from 1 to 10.
- Lane Order is determined by how the lane modules are connected to the timing console. If the lane connected to the console is the first lane, then select Normal. If it is not, select Reversed.
- Lane Label is used to accommodate pools with lane numbering of 1-10 or 0-9. Select the appropriate option.
- Lane Length should be set to the length that matches the pool being used, either 25 yards, 25 meters, or 50 meters. The lane length is used with the race length to calculate how many lengths or touches the timer should expect for that race.

Click OK when finished to save the data, Cancel to exit, or select another tab.

Timer
The Timer tab (Figure 20) configures the inputs and precision of the timer.

- The Arming Delay is the length of time that the touchpad will be inactive following a split time. This is extremely useful for relay exchanges to provide enough time for the swimmers to exit the pool. Typically this is set from 15 to 20 seconds.
- The Flag Time determines the time used to compare the touchpad time to the backup time. If the discrepancy exceeds the flag time, the timer puts an asterisk (*) next to that touchpad time on the final results. Set Flag Time Window On or Off as desired.
• The *Start Input* configures the start signals to receive Normally Open (N.O.) or Normally Closed (N.C.). NO is used if the Daktronics Horn Start 100 or 200 is used at the facility. NC is used if the start system is not produced by Daktronics.

• The *Primary Time* options tell the timer to use the **Touchpads** or **Buttons** for primary event split and finish times. The touchpad is the typical selection.

• The *Lane Module Input* options configure the timer for touchpads and push buttons at the Near end only, or both Near/Far ends of the pool.

• The *Precision* options set the timer to store and print times depending on whether times are displayed to 1/100 or 1/1000 of a second.

  **Note:** 1/100 will show two decimal places, while 1/1000 will show three.

• The *Relay Take-off Platforms* options allow the operator to select the **Type** from **None**, **Button/Daktronics**, or **Omega Platform** and the **Input** (Button 1-3) used for relay exchanges. It’s also possible to select the **Arm Time** of the input from 0.1–1.5 seconds.

Click **OK** when finished to save the data, **Cancel** to exit, or select another tab.

### Console Printer

The **Console Printer** tab (*Figure 21*) configures the console’s built-in printer settings.

*Figure 21: Console Printer Configurations*

Each setting is described below:

• **Print Results** enables the console printer to print the results of the event.

• **Race Log** enables the console printer to print the race log of the event. To view a saved Race Log, exit the *Configure* window and go to **File > Open Log**.

• **Results** determines how the results will be printed: by **Lane** or by **Place**.

• **Print Backups** enables the console printer to print the backup times of the event.

• **Print Splits** enables the console printer to print splits of the event.
  
  o Select **No** to disable this option.
  
  o Select **Cumulative** to print the split times as a cumulative time.
    
    (Example: Lap1 0:58.32, Lap2 1:57.68, Lap3 2:57.39)

  o Select **Subtractive** to print the split times as single lap times
    
    (Example: Lap1 0:58.32, Lap2 0:59.36, Lap3 0:59.71)

• Select the **Number of Copies** to print, up to 5.

Click **OK** when finished to save the data, **Cancel** to exit, or select another tab.
**Pro Printer**

The **Pro Printer** tab (*Figure 22*) configures the printouts for the printer attached to the computer running the pro software.

![Pro Printer Configuration](image)

*Figure 22: Pro Printer Configuration*

The **Printout Format** boxes allow the user to set which printouts will be printed and the order in which they are printed.

- **Finish by Lane** prints the results of the event by lane.
- **Finish by Place** prints the results of the event by place.
- **Cumulative Splits** prints the split times as a cumulative time.
- **Subtractive Splits** prints the split times as single lap times.
- **All Splits** prints the split times.
- **Finish by Lane and Place** prints the results by both *Lane* and *Place*.
- **Finish by Lane w/ Backup** prints the results of the event by *Lane* with backup times.
- **Finish by Place w/ Backup** prints the results of the event by *Place* with backup times.
- **Cumulative Splits w/Backup** prints the split times as a cumulative time along with backup times.
- **Subtractive Splits w/Backup** prints the split times as single lap times along with backup times.
- **All Splits w/ Backup** prints the split times with backup times.
- **Finish by Lane and Place w/ Backup** prints the results by both *Lane* and *Place* with backup times.
- **Finish by Place w/ Exchanges** prints the results of the event by *Place* and shows the times of the relay exchanges.
- **(Page Break)** places the following printout on the next page.
- **(None)** means no reports will print.

Type in a descriptive **Print Header** for the printouts (up to 2 lines). To print the **Race Log**, select **On**. To turn the race log printout off, select **Off**.

Click **OK** when finished to save the data, **Cancel** to exit, or select another tab.

**Notes:**

1) No event may have more than ten print formats. If all formats are set to **None** and the race log is set to **Off**, reports will not print. Otherwise, all printouts can be sent to the console printer.

2) The race log can be printed to a full size printer attached to the Pro computer. Printouts are sent to the computer’s default printer.
SCBD

The SCBD tab (Figure 23) configures the output for both numeric scoreboards and matrix displays. The boxes set the appropriate lines and times, and the option buttons select the order results are displayed.

**Figure 23: SCBD Configuration**

**Numeric (Fixed Digit):** This field configures data for use on numeric scoreboards. The settings are as follows:

- **Number of Lines** designates how many lines there are on the display.
- **Split Hold Time** sets the amount of time the split times will hold on a scoreboard (Default=5 seconds). Enter a value from 1-99 seconds.
- **Finish Page Time** configures the time that finish times will hold on a scoreboard (Default=5 seconds). Enter a value from 1-99 seconds.
- **Results** sets whether the results are displayed by Lane Order or by Place Order.
- **DQ Status** allows users to display that a swimmer was DQ Only or display both the DQ and Time the swimmer finished.
- Select **Show Subtractive Splits** to display split times as single lap times.
- Select **Show Start Reaction Time** to show the time it took from the sound of the horn to when the swimmer left the starting blocks.

**RTD/Matrix:** This field configures data for use on matrix displays. The same options are available as described above, along with the following additional settings:

- Select **Show Place for Intermediate Splits** to display places with split times.
- Use **RTD Offset** to add **5,000**; **10,000**; or **15,000** to the RTD stream in cases where there is more than one pool (and accompanying OmniSport and Pro software) with data from both going to a single display.

Click **OK** when finished to save the data, **Cancel** to exit, or select another tab.

**Results**

The **Results** tab is currently disabled. Click **OK** or **Cancel**, or select another tab.
Event Order
The Event Order tab (Figure 24) displays the current event order and allows the user to edit an event list and change the active list if more than one list has been created.

- Click Set Active File to Open the event file that is to be used.
- Click View Event File to Open any event file created and stored on the computer. Click Exit when finished.
- Click Edit Event File to edit or save a new event file (Figure 25).
  - Click Add Event to insert a new event to the file.
  - Select an event and click Edit Event to modify. Click OK to save.
  - Select an event and click Delete Event to remove it from the file.
  - Users can click Print Event File if desired, Save the event file, or use Save As to overwrite the existing file with a new name.
  - Click Exit when finished.

Click OK when finished to save the data, Cancel to exit, or select another tab.
Comm Ports
The Comm Ports tab (Figure 3) allows the user to select the input/output port types.

The Timer Port Configurations area is used to select the ports for the correct output device used with this system.

- Meet Manager Port sets which protocol (Omni 2000, Omni 6000, or CTS) will be used to communicate with the meet management software via the J6 RESULTS PORT.
- RTD Port sets which protocol (RTD or CTS) is transmitted out of the J5 RTD PORT.
- Scoreboard Port sets which protocol (Multidrop, Multiline Multicast, or Omega) will be transmitted out of the OmniSport 2000 scoreboard outputs (J2 and J3).

The Interface Comm Port area configures which port is used to interface the OmniSport 2000 timing console to the OmniSport 2000 Pro computer.

- Click Configure to change the communication settings (refer to Section 3.1).
- Click Monitor to ensure data is flowing between the two systems (Figure 26).

If no data is flowing, make sure the OmniSport 2000 console is powered on and in the 1-SWIMMING mode. Verify that all cables are properly connected between the computer and the console.

Click OK when finished to save the data, Cancel to exit, or select another tab.

3.5 Lane Colors
Go to Options > Colors to open the Choose Colors window (Figure 27). Here users can define the colors used to represent each lane, along with the text color of each lane.

- Clicking Alternating Color Mode will show just two colors that alternate every other lane.
- Clicking Use Colors In Grids will show the selected lane colors in both Current Race and Stored Race tabs.

Click OK when finished, or click Cancel to exit without saving.
3.6 Typical Operation

Before the Meet

Verify the Configurations
Go to Options > Configure and click on each tab to make sure all configurations have the necessary settings. The system will maintain the setting that it used during the last time it was operated. If any configuration setting was changed while the timer and software were not connected, the system will request that the configuration be synchronized upon reconnection (Figure 8).

Though the configuration will not change unless the user changes them, it is recommended to print the configuration settings so that they can be reentered if there is a sudden loss of power or damage to any equipment that may cause a loss of memory. This can be done from the timer. Press [Menu]>[3]>[3]>[3]>[Enter] on the keypad of the OmniSport 2000 console.

Test the System
The OmniSport 2000 console and Pro Swimming software must be operating properly for a meet to run smoothly. Test the system by following the steps below:

1. Test the start input device by pressing Start. The tone should sound, the strobe should flash, and the time should begin counting on both the timer and the software. If not, ensure all cables are properly connected.
2. On the main application screen, select the Test tab. Test each lane input device by pressing the backup buttons and touching the touchpads. Refer to Main Application Screen Tabs under Section 3.3 for more information on this operation.

If using a display, test run an event to ensure the display shows what is expected.

Set Up Event Order
Go to Options > Configure and select the Event Order tab (Figure 24). From here, a new file can be downloaded or an old file can be opened. Make any adjustments to this file by clicking Edit Event File. Refer to Event Order under Section 3.4 for more details on adding and editing event order files.

Before a Race
Though the event order file establishes the event order, there may be situations where an event changes or combines with another event. All events can be edited during a race from the main application screen. Three things must be remembered when doing this:

Verify Console Settings
The OmniSport 2000 timer must be set to the correct race in order for the system to function accurately. Press [EDIT] on the console to change the event order, insert an event, delete an event, or clear the event order as shown in Section 5 of the OmniSport 2000 manual (ED-13312). Verify that the correct information is shown for the current event.
To edit current race information using the Pro software, select the Current Race tab on the main application screen, which shows information pertaining to the current swimmers and event. **Name**, **Affiliation**, and **Time** are all editable fields. To edit one of these fields, select the desired field and click Edit or double-click in the selected field. To disqualify a lane, select the lane row and click DQ. Click Split Arm All or Finish Arm All to arm the touchpads for split times or finish times respectively. Click STORE PRINT to send the current event data to the printers and save the data into a file.

**Verify the Lengths**
Once the console settings have been verified, the lengths of the pool must be set correctly. To do this, go to Options > Configure (**Figure 19**).

**Lane Length** should be set to the length that matches the pool being used. The lane length is used in conjunction with the race length to calculate how many lengths or touches the timer should expect for that race. Choose from the following three sizes: **25 yards**, **25 meters**, or **50 meters** and then click OK.

**Always Ready Start**
The Always Ready Start feature functions because the OmniSport 2000 timer has an internal time-of-day clock that continually runs when the timer is turned on. The internal clock continues to run even when the race clock has been stopped.

If a start was missed because the timer was not reset (race clock was still running from the previous race), the start impulse is logged in the memory and on the printer. To use the missed start, first reset the timer. If the operator chooses to use the received start signal, the timer will automatically start timing the event by calculating the correct running time. [EDIT] can also be used to retrieve the start impulse used for the last race.

If two independent OmniSport 2000 timers are being used in parallel for an especially critical application and one timer misses a start impulse completely because of a technical problem, a start time may be manually entered when read from the printout of the other timer.

**Example: Editing a Start - If a start is missed because the timer was not reset before the start:**

- The time-of-day of the start impulse will be logged on the printer.
- The OmniSport will inform the operator of the start after the timer is reset.

Reset the timer:
- Click **RESET** and then **Yes** to reset the time to zero. The message in **Figure 28** displays on the screen at this time.
- Accept the missed start by clicking **Yes** and the timer will start from the missed start time. If the missed start is to be ignored, click **No** and the timer will be reset.

If the start time needed was *not* on the LCD, click the **Edit Start Time** button on the upper left-hand corner of the main application screen. In the **Edit Start** window (**Figure 29**), input the correct time and click **OK**.

**Figure 28: Always Ready Start**
a. Alternately, with the timer reset, press [EDIT] on the OmniSport console. This reveals the time-of-day of the last start impulse on the LCD.
b. Confirm that the time-of-day shown is the correct time for the start of the race. The start time may be edited using the number keys.
c. Press [ENTER] to complete the editing operation. The race clock will start and the running time will be correct based on the entered start time.

During a Race
During a race, the lane status may be changed using three editable areas: Lane On/Off, Current Lengths, and the Arming Buttons. The user may monitor the lane status by viewing the Near/Far Lane Indicator, also located on the Pro Swimming main application screen.

Lane Status
During the race, verify the lane status using the editable areas listed below.

- **Lane On/Off** area is a toggle that turns that lane on or off. If the lane is off, no data will be received for this lane. Turn the lane off if no one is using that lane during the current event.
- **Current Lengths** can be changed by clicking the up or down arrows on the right side of this area. The current length will not go beyond the maximum lengths set for the current event.
- **Arming Buttons** are used to change the lane arming status during an event. There may be a time when a swimmer’s touch is not registered by the touchpad. When this happens, use these buttons to change the arming of the lane.

To verify the current arming state of a lane, refer to the *Near* and *Far* lane indicators on the main application screen. **Section 3.3** provides a description of each icon the indicator uses and what it represents.

After a Race
After a race is finished, the following actions must be completed:

- Click **STORE PRINT** to store the current event data into an event file and print the results according to the configurations set in the **Configure** window. Refer to **Section 3.4**.
- Clicking **RESET** will reset the time and begin a new event. **RESET** also stores the current event data into an event file and prints the data according to the configurations set in the **Configure** window. If **STORE PRINT** was not clicked, refer to **Section 3.4**.
- The **Event**, **Heat**, **Length** and **Round** are set by the event order file, but can be edited from the main application screen by clicking the **[↑↓]** buttons to the right of the data fields at the top of the screen. At the end of an event or heat, the user must manually increment the event number, heat number, and round.
Appendix A: Software Revision History

Version 1.00 - Release date: 25 October 2002
  • Initial Swimming release.

Version 1.10 (Beta) - Release Date: 1 November 2002
  • Added functionality for Event Order printouts.
  • Added code to stop console from sending a race with bad/incomplete data in an infinite loop.
  • Added some functionality to the scoreboards property page.

Version 1.11 (Beta) - Release Date: 14 November 2002
  • Fixed registrations issues with Windows® XP.
  • Fixed problem where Omni 6000 style database files weren’t getting added to the list of files sent to the meet manager software.

Version 1.12 (Beta) - Release Date: 5 December 2002
  • Added code to notify the console when requested race data was done being sent.
  • Reset heat number to 1 when the user changes the event number.

Version 1.13 - Release Date: 3 January 2003
  • Changed Title edit box to combo box on main dialog. This allows the user to switch between events by title.
  • Added code to check if multiple events exist with the same event & heat. If that heat is requested, the newest data is returned to Hy-Tek MEET MANAGER.
  • Fixed code so that up and down arrows work correctly, especially in combo boxes.
  • Changed label on test property page from T1 to TP.

Version 1.14 - Release Date: 3 February 2003
  • Fixed problems with the race requests by event and heat numbers from Hy-Tek not returning data.

Version 1.15 - Release Date: 29 July 2003
  • Fixed the software that wouldn't store race information if a swimmer didn't get a touchpad time or a backup time on the final length. The console wouldn't send data for that length, but the software was looking for that data.
  • Fixed the code that was supposed to catch when the same stored race data was being sent over and over again by the console and tell the console to stop sending. The software was sending the response too quickly, and the console was throwing it away. Software now sends the response after any stored race data is received more than five times, not just the race configuration packet.
  • Fixed problems related to printing stored race results while a race is in progress. Also fixed were printing a stored race information from the current event database would print blanks.
  • Added auto-configuration of the user edited times as the user is editing them.
  • Added code to print backup times for a lane, even if no touchpad time was received.

Version 1.16 - Release Date: 23 September 2003
  • Fixed the swimmer's name and affiliation that would get removed from the current race results if a minus touch was pressed.
  • Updated the DakAboutD1g and the location of the license agreement.
• Fixed the names stored in the database that were not correct if a race was reset before it was completed.
• Fixed the database files that were not showing up in the list in the stored races tab.
• Fixed the swimmer's lane number that was sometimes wrong in the stored data.

Version 1.17 - Release Date: 19 November 2003
• Converted to DLStreams communications library.
• Fixed bug that caused software to close if the unlock level is the software wasn't the highest level.
• Fixed where resources were being leaked because the running time wasn't being drawn on the screen correctly.
• Removed use of the CDLRegistry class because it was throwing debug assertions.
• Combined the installs for swimming, diving, and synchronized swimming into a single install using Install Shield 8.
• Made the software conform with new Microsoft Windows® standards by writing all application data to the Documents and Settings folder rather than locally in the Program Files folder.

Version 1.18 - Release Date: 3 March 2004
• Switched back to using separate installs for each PRO software application.
• Added code for the new standard DakAboutDlg, which includes system information.

Version 1.19 - Release Date: 6 July 2004
• Fixed bug that was introduced in version 1.17 where old database files were not being correctly located when a timer requested for race information.

Version 1.1.10 - Release Date: 6 October 2004
• Fixed bug that was causing the Hy-Tek software to have problems getting results from the current database file.

Version 1.1.11 - Release Date: 16 November 2004
• Added functionality for Start Reaction times and Relay Exchanges.
• Fixed bug where power transitions were not being logged correctly in the log file.

Version 1.1.12 - Release Date: 4 January 2005
• Added support for multiple languages.
• Added support for German.

Version 1.1.13 - Release Date: 2 February 2005
• Added support for Chinese (Traditional)
• Added Exchange printout.
• Fixed bug with the “Use Missed Start At:” dialog, which was introduced in version 1.1.12.
• Changed the log file so that Touchpad-Close events were logged rather than Touchpad-Open.

Version 1.1.14 - Release Date: 23 February 2005
• Added code to dump stored race data to a text file if it appears the data being sent from the console is invalid.
• Modified how the certain items are logged in the log file.
• Removed relays 4-6.
Version 1.1.16 - Release Date: 12 May 2006
• Corrected issues with Event Order Editing.
• Added Relay Exchange information to the Current Race tab.

Version 1.1.17 - Release Date: 16 June 2006
• Added/Updated support for other languages (non-English).

Version 1.1.18 - Release Date: 19 January 2007
• Changed way Event Order Files are stored.
• Added Relay-Takeoff Arm Time configuration.
• Added Team Scores.
• Added test patterns for scoreboards.
• Updated some reports to include both subtractive and cumulative splits.
• Automatically change place orders when times are edited in Stored Races.
• Added visual feedback information for communications with console and the console’s printer.
• Added new configurations for Matrix and Fixed-Digit displays.
• Added Start/Exchange times in Stored Races.

Version 1.2.1 - Release Date: 15 October 2009
• Added lane status icons for overly active inputs and low RTOP battery
• Added ability to ignore inputs in test mode by individual lanes, or by near/far end
• Added Multicast as one of the Scoreboard protocol types
• Added more dimming levels as well as auto-dimming for multicast
• Added logging for actions the user performs on the UI.
• Added configuration for RTD Item Number offset
• Added French and Greek language support
• Added new configurations to the SCBD tab
• Added a dialog to let the user choose the TOD in 12 or 24 hour format
• Removed the multiple software protection levels.

Version 1.2.2 - Release Date: 29 December 2009
• Various bug fixes
• Moved the configuration file to the Windows standard location – changes to the file system in Windows Vista/7 was causing problems.
• Added ability to determine what COM ports were attached to modems, and prevent the Pro software from attempting to open those COM ports

Version 1.2.3 - Release Date: 23 October 2012
• Added ability to edit a finish time directly in the Flagged Times dialog.
• Changed non-required text fields in all database tables to allow zero-length strings
• Added logging to the database class when invalid data is trying to be saved
• Added flashing red boxes in the lane status area to better warn users of a potential missed touch.
• Upgraded to Visual Studio 2010 compiler
• Fixed a bug where the lane label configuration 0-9 or 1-10 was not being stored properly in the database.
• Added error message boxes in location where writing to a file may cause a vague exception to occur.
Version 3.0.0 - Release Date: 15 November 2013
- Added support for UDP network communication with the Omnisport
- Fixed issue with French printout where some column headers didn’t format correctly.
- Replaced the Softlocx licensing system with Sentinel
- Fixed issue where Event Order files were not loading properly for view, edit or sending to the Omnisport console as the active event order
- Fixed issue where Event Order File Save As… did not save the file to the correct folder
- Fixed bugs where wrong lanes were being modified when lane labels were set to 0-9 and user tried to DQ or use backup times on a lane
- Fixed bug where DQ status wasn’t always getting set properly on the Current Race tab
- Fixed bug where choose ‘Use Backup’ from the context menu on the Current Race list control sometimes applied the backup time to the wrong lane.
- Added a check of the Time of Day – compare the PC clock and Omnisport clock – alert the user if they differ by more than 15 minutes.

Version 3.0.1 - Release Date: 18 February 2015
- Fixed a typo in Chinese resource string table.
- Only allow users to see network Omnisport 2000 consoles that are running in Swimming mode in the Choose Omnisport dialog.
- Fixed a bug causing the port configuration file to be written to disk repeatedly.

Version 3.0.2 - Release Date: 22 February 2016
- Changed configuration options for Lane Inputs. Options are now either ‘Touchpad’ or ‘Buttons’. Previously there were different options for number of buttons.

Version 3.0.3 - Release Date: 29 March 2016
- Changed the ‘Flag Time’ configuration item – it is always enabled now. The Omnisport 2000 console will use this setting to flag potential issues with multiple button times in addition to touchpad vs button times.