Diagnostic Alert: Communication Failure - Module

Potential Symptoms

  • Blank module(s) on display.
  • "Communication Failure" event on one or more but not all modules in the display.

Environment

  • Products: GS6, GC6, GT6, GT6x, DB-4200, DB-5000, DB-5100, DB-6000, DB-6400, DB-6500, BLD-0100, DXB-0100, DVX, DVN
  • Components: Module, Power Supply, SATA cable
  • Control Systems: Venus Control Suite; System Health

Cause

Causes may include:
  • Module failure
  • Power supply failure
  • SATA cable connection problem

Resolution

Remote Troubleshooting Steps

  • This issue cannot be resolved remotely.

Onsite Troubleshooting Steps

Note: If a large section of modules is out you should look at System Health again and see if the issue may be related to a PLR issue.  If the entire display of modules is showing communication failure you should look at System Health and see if the issue may be related to a PLR issue or if there is an issue with something else that would impact the entire display face, like incoming power or disconnected or failed fiber from the video processor.
  1. Verify module has power.
    • There are status lights above each of the SATA ports (located on the back of each module) that should be flashing or blinking when the module has power.  If you do not have an access panel on the rear of your display, remove the module from the display face to observe status light activity following:  Display Module: How do I remove it?  
    • If you have a multi-meter you can measure the incoming power connector to the module in question for 12VDC, if you do not have a meter you can try plugging in a known working module to the power connector in question to see if it powers on.
    • If the module does not have power locate power supply for the module and confirm power there.
    • If the module is receiving power but is still not showing the status lights, replace the module.
  2. Perform a self test on the module to confirm function.
  3. Reseat SATA cable connections on blank module.
    • If more than one module is blank, reseat connections on the modules on each end of the outage or diagnostics issue.

Watch the Steps:

KB ID: DD1977748


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.