Unable to view Fusion service event logs in Event Viewer, Incorrect permissions.

Potential Symptoms

  • When trying to view Fusion Service Event logs, getting the following error:
    • Located: Event Viewer -> Applications and Service Logs -> Daktronics
    • Event Viewer cannot open the event log or custom view. Verify that Even Log Services is running or query is too long. Access is denied (5)
    • 5-22-2013 1-13-38 PM.jpg
  • When trying to restart the Windows Event Log Service, getting the following error:
    • Windows could not stop the Windows Event Log service on Local Computer.
    • Error 5: Access is denied.
    • 5-22-2013 1-18-29 PM.jpg

Environment

  • Product Family: Software
  • Product: Daktronics Fusion
  • Component:
  • Control System: Venus 1500 v4.18.1 or greater

Cause

  • There are missing or altered permissions when trying to create or access the Fusion Event Log directory.

Resolution

Step 1: Give NT Service\eventlog full permissions to Event Viewer Directories.

  1. Open Windows Explorer window, type the following:
    • %SystemRoot%\System32\winevt\ 
  2. Hit [Enter] Key, and you should be directed to the Windows Event Folder.
    • If not, manually navigate to the folder location.
  3. Right-click on the Logs folder and choose Properties.
    • If Windows Vista, 7 or 8, Click on Security tab and click Edit.
  4. Click Add.
  5. Under Enter the objects name to select, type NT Service\eventlog.
  6. Click Check Names.
  7. Name should be found and can click Ok.
    • If you get a prompt about Name not found, check to see if eventlog is already listed under Group or user names.
  8. If already listed or you were able to add to the Group or user names list, make sure it has Full Control by clicking Full Control.
  9. Click Apply and Ok.
  10. Restart the Computer.

Step 2: Run a Repair on the Daktronics Fusion Service.

  1. Go to Windows Start Menu.
  2. Click Control Panel.
  3. Click Add or Remove Programs or Program and Features.
  4. Highlight or select Daktronics Fusion.
  5. Click Change/Modify or Repair.
    • Some software programs and Windows Operating Systems may require you to select the Repair option in the Windows Installer and click Continue or Next through the remaining installer prompts.
  6. Allow Windows Installer to finish repair.
  7. Click Yes to restart the Computer if prompted.

Step 3: Check to see if you can again view the Fusion Event Logs.

KB ID: DD2554762


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