Are displays with MDC controllers compatible with Venus 1500 v4 software?

Question

  • Are displays with MDC controllers compatible with Venus 1500 v4 software?

Environment

  • Galaxy Message Centers (MDC Controller)
  • Outdoor: AF-3010, AF-3020, AF-3050, AF-3060, AF-3080, AF-3090
  • Indoor: AE-3010
  • Venus 1500 v4

Answer/Steps

  • Venus 1500 v4 is not a compatible environment for displays using MDC controllers as v4 was made to communicate with displays using a newer protocol. It is recommended to utilize Venus 1500 v3 to control displays with MDC controllers.

KB ID: DD3363172


Fill out my online form.
DISCLAIMER: Use of this content may void the equipment warranty, please read this DISCLAIMER prior to performing any service of the equipment.