D-Link (Rev D) USB to Ethernet adapter, Unable to install driver

Symptoms

  • Installed the D-Link driver and it does not show up in device manager or has the following alert: Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52).

Environment

  • D-Link (DUB-E100) (Hardware version D1)
    • USB to Ethernet Adapter
    • Note: The D-Link hardware revision is printed on the label.
      D-Link Revision.png

Cause

  • Not installing the correct driver.

Resolution

  • Right click on the provided driver disk in computer.
  • Select Open.
  • Double click folder 1.2.
  • Run DLink.exe.

Work Around

  1. Go to the D-Link website.  http://support.dlink.com/ProductInfo.aspx?m=DUB-E100
  2. ​​​Select D for hardware version in the drop down menu.
  3. Select Download for the Windows driver.
  4. Install the driver.

KB ID: DD3308434


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