Venus 1500 timing out when trying to publish messages to display, Slower data transfer rate

Potential Symptoms

  • Connected to the display in Venus 1500 v4, but connection keeps timing out when trying to publish messages to the display.
  • May be getting errors in alerts when publishing:
    • Communication with the display timed out.
    • The data received from the display is incorrect.
    • Unable to connect to the display.
  • Publishing speeds are extremely slow; transferring over a 3G network or EBR radios.  
  • Smaller messages (30 - 400KB) publish to the display in time, but larger messages (2 - 4MB) will not publish.

Environment

  • Product Family: Message Displays
  • Product: Galaxy
  • Component: Verizon, Sprint, AT&T CDMA, Ethernet Bridge Radios
  • Control System: Venus 1500 v4

Cause

  • Slow data transfer rate is causing Venus software to timeout when trying to publish messages.
    • Or, the Venus 1500 Ethernet communication timeout is set below the automatic average (30 sec).

Resolution

  1. Increase the timeout of TCP/IP to desired amount until messages are able to send.
  2. If timeout has been maxed out (900 seconds) and the messages are still not publishing, then it is advised that the customer tries to use a different data service provider with better coverage (Verizon, Sprint, or AT&T).
  3. If using EBR Radios reference Poor or no communication through EBRs, High broadcast versus unicast packets, DD2167938 to ensure network traffic is not impacting your transfer rates through the radios.

For Temporary Operation

  1. If there are no alternate data service providers (CDMA) or if signal strength can not be increased (EBR) then the size of messages will need to be controlled.
  2. Try to avoid using large video files as they are larger in size and will almost always timeout if the coverage is bad.
  3. If there are messages with multiple layouts within them, split the layouts into separate messages and publish them to the display separately. This will lower the overall size of the messages, enabling faster transfers.
  4. Try to keep messages under 1MB with TCP/IP timeout set to 900 seconds (Allows the maximum time to transfer data).
  5. If still unable to send messages due to timeout, an alternative communication method will be needed.

KB ID: DD2873682


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.